]> code.ossystems Code Review - openembedded-core.git/commitdiff
logrotate: update to 3.16.0
authorAlexander Kanavin <alex.kanavin@gmail.com>
Thu, 30 Apr 2020 09:58:01 +0000 (11:58 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 3 May 2020 14:38:03 +0000 (15:38 +0100)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/logrotate/logrotate/0001-Update-the-manual.patch [moved from meta/recipes-extended/logrotate/logrotate/update-the-manual.patch with 70% similarity]
meta/recipes-extended/logrotate/logrotate/act-as-mv-when-rotate.patch
meta/recipes-extended/logrotate/logrotate/disable-check-different-filesystems.patch
meta/recipes-extended/logrotate/logrotate_3.16.0.bb [moved from meta/recipes-extended/logrotate/logrotate_3.15.1.bb with 95% similarity]

similarity index 70%
rename from meta/recipes-extended/logrotate/logrotate/update-the-manual.patch
rename to meta/recipes-extended/logrotate/logrotate/0001-Update-the-manual.patch
index 725567e0c91e9d6515be5ce583414e981dfb223f..50a3852078fdc2519e397cfe1e28eca9e9ccf460 100644 (file)
@@ -1,4 +1,4 @@
-From bf22e8805df69344f6f20cea390e829a22fa741b Mon Sep 17 00:00:00 2001
+From 3e2cfa88b6538bb0fee3d9a6e99622055d05ac4a Mon Sep 17 00:00:00 2001
 From: Robert Yang <liezhi.yang@windriver.com>
 Date: Tue, 17 Feb 2015 21:14:37 -0800
 Subject: [PATCH] Update the manual
@@ -8,23 +8,24 @@ Update the manual for rotating on different filesystems.
 Upstream-Status: Pending
 
 Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+
 ---
  logrotate.8.in | 10 ++++------
  1 file changed, 4 insertions(+), 6 deletions(-)
 
 diff --git a/logrotate.8.in b/logrotate.8.in
-index 951e406..581bf48 100644
+index 98fea91..70b4c44 100644
 --- a/logrotate.8.in
 +++ b/logrotate.8.in
-@@ -445,12 +445,10 @@ Do not rotate the log if it is empty (this overrides the \fBifempty\fR option).
+@@ -202,12 +202,10 @@ at all (use with caution, may waste performance and disk space). Default is 0.
  
  .TP
  \fBolddir \fIdirectory\fR
--Logs are moved into \fIdirectory\fR for rotation. The \fIdirectory\fR must be
+-Logs are moved into \fIdirectory\fR for rotation.  The \fIdirectory\fR must be
 -on the same physical device as the log file being rotated, unless \fBcopy\fR,
--\fBcopytruncate\fR or \fBrenamecopy\fR option is used. The \fIdirectory\fR
+-\fBcopytruncate\fR or \fBrenamecopy\fR option is used.  The \fIdirectory\fR
 -is assumed to be relative to the directory holding the log file
--unless an absolute path name is specified. When this option is used all
+-unless an absolute path name is specified.  When this option is used all
 -old versions of the log end up in \fIdirectory\fR.  This option may be
 +Logs are moved into \fIdirectory\fR for rotation. The \fIdirectory\fR
 +is assumed to be relative to the directory holding the log file unless
@@ -34,5 +35,5 @@ index 951e406..581bf48 100644
  
  .TP
 -- 
-1.8.3.1
+2.24.0
 
index 79805b51481ce51f5b6aec6378a831c16b5a7da1..acef5ccbe93d11bb46e5179a849dea37f2ef2446 100644 (file)
@@ -1,4 +1,4 @@
-From c637948ebab5aff5641700c5cf613321ca0a6e6b Mon Sep 17 00:00:00 2001
+From ef1ea905831c5bcd63e04149571c10d75ff8f028 Mon Sep 17 00:00:00 2001
 From: Robert Yang <liezhi.yang@windriver.com>
 Date: Tue, 17 Feb 2015 21:08:07 -0800
 Subject: [PATCH] Act as the "mv" command when rotate log
@@ -9,15 +9,16 @@ read and write.
 Upstream-Status: Pending
 
 Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+
 ---
  logrotate.c | 71 ++++++++++++++++++++++++++++++++++++++++++++---------
  1 file changed, 59 insertions(+), 12 deletions(-)
 
 diff --git a/logrotate.c b/logrotate.c
-index 54dac90..bf3ec23 100644
+index 25902bc..afa1a90 100644
 --- a/logrotate.c
 +++ b/logrotate.c
-@@ -1360,6 +1360,53 @@ static int findNeedRotating(struct logInfo *log, int logNum, int force)
+@@ -1434,6 +1434,53 @@ static int findNeedRotating(struct logInfo *log, int logNum, int force)
      return 0;
  }
  
@@ -71,7 +72,7 @@ index 54dac90..bf3ec23 100644
  /* find the rotated file with the highest index */
  static int findLastRotated(const struct logNames *rotNames,
                             const char *fileext, const char *compext)
-@@ -1800,15 +1847,15 @@ static int prerotateSingleLog(struct logInfo *log, int logNum,
+@@ -1911,15 +1958,15 @@ static int prerotateSingleLog(struct logInfo *log, int logNum,
              }
  
              message(MESS_DEBUG,
@@ -90,7 +91,7 @@ index 54dac90..bf3ec23 100644
                              oldName, newName, strerror(errno));
                      hasErrors = 1;
                  }
-@@ -1891,21 +1938,21 @@ static int rotateSingleLog(struct logInfo *log, int logNum,
+@@ -2002,10 +2049,10 @@ static int rotateSingleLog(struct logInfo *log, int logNum,
                      return 1;
                  }
  
@@ -104,7 +105,8 @@ index 54dac90..bf3ec23 100644
                              log->files[logNum], tmpFilename,
                              strerror(errno));
                      hasErrors = 1;
-                 }
+@@ -2014,11 +2061,11 @@ static int rotateSingleLog(struct logInfo *log, int logNum,
+                 free(tmpFilename);
              }
              else {
 -                message(MESS_DEBUG, "renaming %s to %s\n", log->files[logNum],
@@ -118,7 +120,7 @@ index 54dac90..bf3ec23 100644
                              log->files[logNum], rotNames->finalName,
                              strerror(errno));
                      hasErrors = 1;
-@@ -2297,7 +2344,7 @@ static int rotateLogSet(struct logInfo *log, int force)
+@@ -2424,7 +2471,7 @@ static int rotateLogSet(struct logInfo *log, int force)
      return hasErrors;
  }
  
@@ -127,7 +129,7 @@ index 54dac90..bf3ec23 100644
  {
      struct logState *p;
      FILE *f;
-@@ -2460,7 +2507,7 @@ static int writeState(const char *stateFilename)
+@@ -2629,7 +2676,7 @@ static int writeState(const char *stateFilename)
          fclose(f);
  
      if (error == 0) {
@@ -135,8 +137,8 @@ index 54dac90..bf3ec23 100644
 +        if (mvFile(tmpFilename, stateFilename, log, prev_acl)) {
              unlink(tmpFilename);
              error = 1;
-             message(MESS_ERROR, "error renaming temp state file %s\n",
-@@ -2805,7 +2852,7 @@ int main(int argc, const char **argv)
+             message(MESS_ERROR, "error renaming temp state file %s to %s\n",
+@@ -2987,7 +3034,7 @@ int main(int argc, const char **argv)
          rc |= rotateLogSet(log, force);
  
      if (!debug)
@@ -145,6 +147,3 @@ index 54dac90..bf3ec23 100644
  
      return (rc != 0);
  }
--- 
-2.18.1
-
index 96ff098a3f2301f3595fff2539f2505ea304255a..9ba531f815c0ccf78d3fd3432ea7a5d61cf45b31 100644 (file)
@@ -1,4 +1,4 @@
-From e47796c8e8270a3d14f0b06af8a9e916c2225514 Mon Sep 17 00:00:00 2001
+From a3fdf3dbdd6ecc0f2550a765dcb9bb274bce8ea8 Mon Sep 17 00:00:00 2001
 From: Robert Yang <liezhi.yang@windriver.com>
 Date: Tue, 8 Jan 2019 06:27:06 +0000
 Subject: [PATCH] Disable the check for different filesystems
@@ -9,18 +9,19 @@ disable the check for different filesystems.
 Upstream-Status: Pending
 
 Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+
 ---
  config.c | 9 ---------
  1 file changed, 9 deletions(-)
 
 diff --git a/config.c b/config.c
-index 633b843..99a4a3b 100644
+index f027c7e..026136c 100644
 --- a/config.c
 +++ b/config.c
-@@ -1765,15 +1765,6 @@ duperror:
-                                     goto error;
-                                 }
+@@ -1873,15 +1873,6 @@ duperror:
                              }
+                             free(ld);
 -
 -                            if (sb.st_dev != sb2.st_dev
 -                                    && !(newlog->flags & (LOG_FLAG_COPYTRUNCATE | LOG_FLAG_COPY | LOG_FLAG_TMPFILENAME))) {
@@ -33,6 +34,3 @@ index 633b843..99a4a3b 100644
                          }
                      }
  
--- 
-2.18.1
-
similarity index 95%
rename from meta/recipes-extended/logrotate/logrotate_3.15.1.bb
rename to meta/recipes-extended/logrotate/logrotate_3.16.0.bb
index 7c7d51b39ed933066f236dc15d8d648107a2cd6b..2b6ee0a19a3ae3708b94db36bbc34d70127f5c58 100644 (file)
@@ -21,12 +21,12 @@ UPSTREAM_CHECK_REGEX = "logrotate-(?P<pver>\d+(\.\d+)+).tar"
 
 SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.xz \
             file://act-as-mv-when-rotate.patch \
-            file://update-the-manual.patch \
+            file://0001-Update-the-manual.patch \
             file://disable-check-different-filesystems.patch \
             "
 
-SRC_URI[md5sum] = "afe109afea749c306ff489203fde6beb"
-SRC_URI[sha256sum] = "491fec9e89f1372f02a0ab66579aa2e9d63cac5178dfa672c204c88e693a908b"
+SRC_URI[md5sum] = "faf729e0e24bfaafaa677bc6deb46ed8"
+SRC_URI[sha256sum] = "442f6fdf61c349eeae5f76799878b88fe45a11c8863a38b618bac6988f4a7ce5"
 
 PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'acl selinux', d)}"