]> code.ossystems Code Review - openembedded-core.git/commitdiff
Workaround issue with latest version of pseudo.
authorMark Hatle <mark.hatle@windriver.com>
Fri, 14 Jan 2011 20:37:59 +0000 (14:37 -0600)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 18 Jan 2011 17:54:52 +0000 (17:54 +0000)
The latest version of pseudo occasionally caches on an execvp.  This should
resolve the issue.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch [new file with mode: 0644]
meta/recipes-devtools/pseudo/pseudo_git.bb

diff --git a/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch b/meta/recipes-devtools/pseudo/pseudo/pseudo-exec-crash.patch
new file mode 100644 (file)
index 0000000..a73ed64
--- /dev/null
@@ -0,0 +1,20 @@
+The cached data values were being collected when an OP_EXEC call was made.
+This is incorrect as the values are only for logging purposes.  It's believed
+this caused an occasional crash in certain instances.
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+
+diff --git a/pseudo.c b/pseudo.c
+index efee436..62f28f3 100644
+--- a/pseudo.c
++++ b/pseudo.c
+@@ -1021,7 +1021,8 @@ pseudo_op(pseudo_msg_t *msg, const char *program, const char *tag) {
+       if (msg->op != OP_MAY_UNLINK &&
+           msg->op != OP_DID_UNLINK &&
+           msg->op != OP_CANCEL_UNLINK &&
+-          msg->op != OP_UNLINK) {
++          msg->op != OP_UNLINK &&
++          msg->op != OP_EXEC ) {
+               cache_msg = *msg;
+               if (path_by_ino) {
index df73696a7eeefa88390b1c803e805083e570723d..6645033c3eeb852068750defc4a976dccd43789a 100644 (file)
@@ -10,6 +10,7 @@ PR = "r16"
 
 SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \
            file://static_sqlite.patch \
+          file://pseudo-exec-crash.patch \
          "
 
 FILES_${PN} = "${libdir}/libpseudo.so ${bindir}/* ${localstatedir}/pseudo"