]> code.ossystems Code Review - openembedded-core.git/commitdiff
- Updates Dates svn package
authorChris Lord <chris@openedhand.com>
Wed, 19 Jul 2006 16:12:45 +0000 (16:12 +0000)
committerChris Lord <chris@openedhand.com>
Wed, 19 Jul 2006 16:12:45 +0000 (16:12 +0000)
- Add Dates 0.1 package
- Add gtk-icon-cache bbclass to run gtk-update-icon-cache in postinst/postrm
- Update gconf class to add gconf to DEPENDS

git-svn-id: https://svn.o-hand.com/repos/poky/trunk@513 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/classes/gconf.bbclass
openembedded/classes/gtk-icon-cache.bbclass [new file with mode: 0644]
openembedded/conf/distro/poky.conf
openembedded/packages/dates/dates_0.1.bb [new file with mode: 0755]
openembedded/packages/dates/dates_svn.bb

index b0c5723873d910158e084ee68c2b5e0427877206..686f8e6596f152dc3821e17ead38fcb7043d3872 100644 (file)
@@ -1,3 +1,5 @@
+DEPENDS += "gconf"
+
 gconf_postinst() {
 if [ "$1" = configure ]; then
        if [ "x$D" != "x" ]; then
diff --git a/openembedded/classes/gtk-icon-cache.bbclass b/openembedded/classes/gtk-icon-cache.bbclass
new file mode 100644 (file)
index 0000000..0f68e68
--- /dev/null
@@ -0,0 +1,38 @@
+FILES_${PN} += "${datadir}/icons/hicolor"
+
+gtk-icon-cache_postinst() {
+if [ "x$D" != "x" ]; then
+        exit 1
+fi
+gtk-update-icon-cache -q /usr/share/icons/hicolor
+}
+
+gtk-icon-cache_postrm() {
+gtk-update-icon-cache -q /usr/share/icons/hicolor
+}
+
+python populate_packages_append () {
+       import os.path
+       packages = bb.data.getVar('PACKAGES', d, 1).split()
+       workdir = bb.data.getVar('WORKDIR', d, 1)
+       
+       for pkg in packages:
+               icon_dir = '%s/install/%s/%s/icons/hicolor' % (workdir, pkg, bb.data.getVar('datadir', d, 1))
+               if not os.path.exists(icon_dir):
+                       continue
+               
+               bb.note("adding gtk-icon-cache postinst and postrm scripts to %s" % pkg)
+               
+               postinst = bb.data.getVar('pkg_postinst_%s' % pkg, d, 1) or bb.data.getVar('pkg_postinst', d, 1)
+               if not postinst:
+                       postinst = '#!/bin/sh\n'
+               postinst += bb.data.getVar('gtk-icon-cache_postinst', d, 1)
+               bb.data.setVar('pkg_postinst_%s' % pkg, postinst, d)
+
+               postrm = bb.data.getVar('pkg_postrm_%s' % pkg, d, 1) or bb.data.getVar('pkg_postrm', d, 1)
+               if not postrm:
+                       postrm = '#!/bin/sh\n'
+               postrm += bb.data.getVar('gtk-icon-cache_postrm', d, 1)
+               bb.data.setVar('pkg_postrm_%s' % pkg, postrm, d)
+}
+
index 35eb247ba3609669192af5ae9677c587705f61d3..36af6b8b4aa198935cdc869c8b3adbad99069eb0 100644 (file)
@@ -71,7 +71,7 @@ PREFERRED_PROVIDER_tslib ?= tslib
 SRCDATE_gconf-dbus ?= "20060119"
 SRCDATE_gnome-vfs-dbus ?= "20060119"
 SRCDATE_contacts ?= "20060707"
-SRCDATE_dates ?= "20060707"
+SRCDATE_dates ?= "20060719"
 SRCDATE_gtkhtml2 ?= "20060323"
 SRCDATE_web ?= "20060613"
 SRCDATE_eds-dbus ?= "20060707"
diff --git a/openembedded/packages/dates/dates_0.1.bb b/openembedded/packages/dates/dates_0.1.bb
new file mode 100755 (executable)
index 0000000..b13fb01
--- /dev/null
@@ -0,0 +1,19 @@
+LICENSE = "LGPL"
+SECTION = "x11"
+DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
+MAINTAINER = "Chris Lord <chris@openedhand.com>"
+DESCRIPTION = "Dates is a calendar application."
+
+SRC_URI = "http://projects.o-hand.com/sources/dates/dates-0.1.tar.gz"
+
+inherit autotools pkgconfig gtk-icon-cache
+
+# EXTRA_OECONF = "--disable-debug"
+
+FILES_${PN} += "${datadir}/pixmaps/dates.png"
+
+do_install_append () {
+       install -d ${D}/${datadir}/pixmaps
+       install -m 0644 ${D}/${datadir}/icons/hicolor/48x48/apps/dates.png ${D}/${datadir}/pixmaps/
+}
+
index 3d658aae54d3b244bc202d4bd61e1e714184f062..408ba5da511dbb35250e0d78bc90b24c9f3de36e 100755 (executable)
@@ -4,13 +4,16 @@ DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
 DESCRIPTION = "Dates is a calendar application."
 
-PR = "r5"
-
-PV = "0.0+svn${SRCDATE}"
+PV = "0.1+svn${SRCDATE}"
 S = "${WORKDIR}/trunk"
 
 SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http"
 
-inherit autotools pkgconfig
+inherit autotools pkgconfig gtk-icon-cache
+
+FILES_${PN} += "${datadir}/pixmaps/dates.png"
 
-CFLAGS_prepend = " -DFRAMES=3 "
+do_install_append () {
+       install -d ${D}/${datadir}/pixmaps
+       install -m 0644 ${D}/${datadir}/icons/hicolor/48x48/apps/dates.png ${D}/${datadir}/pixmaps/
+}