]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc-cross: Fold common configuration into gcc-cross.inc
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Aug 2013 09:31:56 +0000 (09:31 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 22 Aug 2013 17:30:06 +0000 (18:30 +0100)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gcc/gcc-cross.inc
meta/recipes-devtools/gcc/gcc-cross_4.7.bb
meta/recipes-devtools/gcc/gcc-cross_4.8.bb

index 2913df79b39c02cb041c5583f1e0d434e301a007..c3542e297c590cbf89d609ae9a85b0f152556b2b 100644 (file)
@@ -108,3 +108,15 @@ STOP
 }
 
 EXTRA_OECONF_append_sh4 = " --with-multilib-list= --enable-incomplete-targets "
+
+EXTRA_OECONF += "--disable-libunwind-exceptions \
+                 --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
+                 --with-system-zlib "
+
+EXTRA_OECONF_PATHS = " \
+                      --with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
+                      --with-sysroot=${STAGING_DIR_TARGET} \
+                      --with-build-sysroot=${STAGING_DIR_TARGET}"
+
+
+ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
index b02ea13de28a9fefef851208cdd0bf0066c984ea..b43cca0c526a99bbf4a0d9413988635b0960ce96 100644 (file)
@@ -1,14 +1,3 @@
 require recipes-devtools/gcc/gcc-${PV}.inc
 require gcc-cross.inc
 
-EXTRA_OECONF += "--disable-libunwind-exceptions \
-                 --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
-                 --with-system-zlib "
-
-EXTRA_OECONF_PATHS = " \
-                      --with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
-                      --with-sysroot=${STAGING_DIR_TARGET} \
-                      --with-build-sysroot=${STAGING_DIR_TARGET}"
-
-
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"
index b02ea13de28a9fefef851208cdd0bf0066c984ea..b43cca0c526a99bbf4a0d9413988635b0960ce96 100644 (file)
@@ -1,14 +1,3 @@
 require recipes-devtools/gcc/gcc-${PV}.inc
 require gcc-cross.inc
 
-EXTRA_OECONF += "--disable-libunwind-exceptions \
-                 --with-mpfr=${STAGING_DIR_NATIVE}${prefix_native} \
-                 --with-system-zlib "
-
-EXTRA_OECONF_PATHS = " \
-                      --with-gxx-include-dir=${STAGING_DIR_TARGET}${target_includedir}/c++ \
-                      --with-sysroot=${STAGING_DIR_TARGET} \
-                      --with-build-sysroot=${STAGING_DIR_TARGET}"
-
-
-ARCH_FLAGS_FOR_TARGET += "-isystem${STAGING_DIR_TARGET}${target_includedir}"