]> code.ossystems Code Review - openembedded-core.git/commitdiff
icon-naming-utils-native: Fix long path to perl in icon-name-mapping
authorTom Rini <tom_rini@mentor.com>
Mon, 18 Jul 2011 15:57:31 +0000 (08:57 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Jul 2011 09:46:45 +0000 (10:46 +0100)
This is 5396e0868cf89787746fa6341ddb1f271a770595 in oe.dev but here we
instead use the nativeperl wrapper.

Signed-off-by: Tom Rini <tom_rini@mentor.com>
meta/recipes-devtools/icon-naming-utils/icon-naming-utils-native_0.8.7.bb

index d34fb0315d070e6d7335affab3e165712be38820..4760c9627e7e6551d0486713389d87fbd4dd68f7 100644 (file)
@@ -1,6 +1,6 @@
 LICENSE = "GPLv2"
 DEPENDS = "libxml-simple-perl-native"
-PR = "r2"
+PR = "r3"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
 
@@ -9,3 +9,8 @@ SRC_URI = "http://tango.freedesktop.org/releases/icon-naming-utils-0.8.7.tar.gz"
 S = "${WORKDIR}/icon-naming-utils-${PV}"
 
 inherit autotools native perlnative
+
+do_configure_append() {
+       # Make sure we use our nativeperl wrapper.
+       sed -i -e "1s:#!.*:#!/usr/bin/env nativeperl:" ${S}/icon-name-mapping.pl.in
+}