]> code.ossystems Code Review - openembedded-core.git/commitdiff
kernel.bbclass, task-base: remove references to obsolete bluez-dtl1-workaround
authorPhil Blundell <pb@pbcl.net>
Thu, 7 Jul 2011 16:02:24 +0000 (17:02 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 12 Jul 2011 14:16:09 +0000 (15:16 +0100)
Signed-off-by: Phil Blundell <philb@gnu.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/kernel.bbclass
meta/recipes-core/tasks/task-base.bb

index 1a71df64bad5a50a0da05d3d42b0fcf2f23b3a88..e441748bf8c9f40c437c17620392e4593c37e42a 100644 (file)
@@ -243,11 +243,6 @@ ALLOW_EMPTY_kernel = "1"
 ALLOW_EMPTY_kernel-base = "1"
 ALLOW_EMPTY_kernel-image = "1"
 
-# Userspace workarounds for kernel modules issues
-# This is shame, fix the kernel instead!
-DEPENDS_kernel-module-dtl1-cs = "bluez-dtl1-workaround"
-RDEPENDS_kernel-module-dtl1-cs = "bluez-dtl1-workaround"
-
 pkg_postinst_kernel-image () {
 if [ ! -e "$D/lib/modules/${KERNEL_VERSION}" ]; then
        mkdir -p $D/lib/modules/${KERNEL_VERSION}
index 97a854c2ef33e85dc2cab5d3381f5af880da521d..99b7e17a692b97852ff32f3ebdb170ade6f2946d 100644 (file)
@@ -80,7 +80,6 @@ RDEPENDS_task-base = "\
     ${@base_contains('COMBINED_FEATURES', 'irda', 'task-base-irda', '',d)} \
     ${@base_contains('COMBINED_FEATURES', 'pci', 'task-base-pci', '',d)} \
     ${@base_contains('COMBINED_FEATURES', 'pcmcia', 'task-base-pcmcia', '',d)} \
-    ${@base_contains('COMBINED_FEATURES', 'pcmcia', 'bluez-dtl1-workaround', '',d)} \
     ${@base_contains('COMBINED_FEATURES', 'usbgadget', 'task-base-usbgadget', '',d)} \
     ${@base_contains('COMBINED_FEATURES', 'usbhost', 'task-base-usbhost', '',d)} \
     ${@base_contains('COMBINED_FEATURES', 'bluetooth', 'task-base-bluetooth', '',d)} \
@@ -99,7 +98,6 @@ RDEPENDS_task-base = "\
     ${@base_contains('DISTRO_FEATURES', 'raid', 'task-base-raid', '',d)} \
     ${@base_contains('DISTRO_FEATURES', 'zeroconf', 'task-base-zeroconf', '',d)} \
     "
-# bluez-dtl1-workaround above is workaround for bitbake not handling DEPENDS on it in
 
 
 RRECOMMENDS_task-base = "\
@@ -229,10 +227,7 @@ RRECOMMENDS_task-base-bluetooth = "\
     ${@base_contains('COMBINED_FEATURES', 'pcmcia', 'kernel-module-bluecard-cs', '',d)} \
     ${@base_contains('COMBINED_FEATURES', 'pcmcia', 'kernel-module-bluetoothuart-cs', '',d)} \
     ${@base_contains('COMBINED_FEATURES', 'pcmcia', 'kernel-module-dtl1-cs', '',d)} \
-    ${@base_contains('COMBINED_FEATURES', 'pcmcia', 'bluez-dtl1-workaround', '',d)} \
     "
-# bluez-dtl1-workaround above is workaround for bitbake not handling DEPENDS on it in
-# kernel.bbclass. It should be there as long as kernel-module-dtl1-cs is, but not longer.
 
 RDEPENDS_task-base-irda = "\
     irda-utils"