]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl-native: Ensure the wrapper appends to any existing PERL5LIB
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 17 Jan 2011 15:15:13 +0000 (15:15 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 17 Jan 2011 15:15:13 +0000 (15:15 +0000)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/perl-native_5.12.2.bb

index 3fb22db44227a37ea99ceb041601c3110f8da9b4..14da569ba76c8992734327905e7b51f877f63dbc 100644 (file)
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
 LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
                    file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
 DEPENDS = "virtual/db-native gdbm-native"
-PR = "r1"
+PR = "r2"
 
 LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
                     file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
@@ -89,7 +89,7 @@ do_install () {
                install $i ${D}${libdir}/perl/${PV}/CORE
        done
 
-       create_wrapper ${D}${bindir}/perl PERL5LIB=${STAGING_LIBDIR}/perl/5.12.2:${STAGING_LIBDIR}/perl/
+       create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/5.12.2:${STAGING_LIBDIR}/perl/'
 }
 do_install_append_nylon() {
        # get rid of definitions not supported by the gcc version we use for nylon...