]> code.ossystems Code Review - openembedded-core.git/commitdiff
grub-efi: add PACKAGECONFIG for grub-mount and device-mapper
authorRobert Yang <liezhi.yang@windriver.com>
Thu, 2 Apr 2015 08:55:16 +0000 (01:55 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 13 Apr 2015 21:28:32 +0000 (22:28 +0100)
We had PACKAGECONFIGs for grub_2.00 and grub_git, we also need them for
grub-efi, otherwise there might be failures as:
grub-2.00/util/grub-mount.c:37:23: fatal error: fuse/fuse.h: No such file or directory

Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-bsp/grub/grub2.inc
meta/recipes-bsp/grub/grub_2.00.bb
meta/recipes-bsp/grub/grub_git.bb

index 39469576ccacc55828c103b8883b70fda6fe8be1..4d9e3c7287a9cb6a4344dc1d58edcb349e37e554 100644 (file)
@@ -35,6 +35,10 @@ COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'
 
 inherit autotools gettext texinfo
 
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse"
+PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,lvm2"
+
 # grub and grub-efi's sysroot/${datadir}/grub/grub-mkconfig_lib are
 # conflicted, remove it since no one uses it.
 SYSROOT_PREPROCESS_FUNCS_class-target += "remove_sysroot_mkconfig_lib"
index a11e960fe5898a5ef391f597b52099b336a50800..88a709edb6106012bfd64e1f58792b6a624e0645 100644 (file)
@@ -6,10 +6,6 @@ PR = "r1"
 FILES_${PN}-dbg += "${libdir}/${BPN}/i386-pc/.debug"
 
 
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse"
-PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,lvm2"
-
 EXTRA_OECONF = "--with-platform=pc --disable-grub-mkfont --program-prefix="" \
                --enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
 
index 3ab675b29828a455d7d70b0487983a087083171b..c2760c9ace9cd65dad9f46701ad2e7b13df98f6b 100644 (file)
@@ -20,10 +20,6 @@ COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*)-(linux.*|freebsd.*)'
 
 inherit autotools gettext texinfo
 
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[grub-mount] = "--enable-grub-mount,--disable-grub-mount,fuse"
-PACKAGECONFIG[device-mapper] = "--enable-device-mapper,--disable-device-mapper,lvm2"
-
 # configure.ac has code to set this automagically from the target tuple
 # but the OE freeform one (core2-foo-bar-linux) don't work with that.