]> code.ossystems Code Review - openembedded-core.git/commitdiff
bzip2: fix ptest execution failure
authorMaxin B. John <maxin.john@enea.com>
Mon, 5 May 2014 20:42:22 +0000 (22:42 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 15 May 2014 22:24:04 +0000 (23:24 +0100)
This patch fixes the bzip2 ptest execution failure:

root@qemux86:/usr/lib/bzip2/ptest# ./run-ptest
make: *** No rule to make target 'runtest'.

(This is also applicable for daisy branch)

Signed-off-by: Maxin B. John <maxin.john@enea.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-extended/bzip2/bzip2_1.0.6.bb

index e9d745d76338984ef13a6f35873eed15ec093f86..9dd9e6a1f9ccaccd920a0ea3cd1e4fa0fc333493 100644 (file)
@@ -11,7 +11,7 @@ PR = "r5"
 SRC_URI = "http://www.bzip.org/${PV}/${BPN}-${PV}.tar.gz \
            file://configure.ac \
            file://run-ptest \
-          file://Makefile.am"
+           file://Makefile.am"
 
 SRC_URI[md5sum] = "00b516f4704d4a7cb50a1d97e6e8e15b"
 SRC_URI[sha256sum] = "a2848f34fcd5d6cf47def00461fcb528a0484d8edef8208d6d2e2909dc61d9cd"
@@ -35,6 +35,7 @@ do_extraunpack () {
 addtask extraunpack after do_unpack before do_patch
 
 do_install_ptest () {
+       cp -f ${B}/Makefile ${D}${PTEST_PATH}/Makefile
        sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
 }