]> code.ossystems Code Review - openembedded-core.git/commitdiff
cmake-native: Enable ccmake by default and depend on ncurses
authorNathan Rossi <nathan@nathanrossi.com>
Wed, 3 Apr 2019 05:37:02 +0000 (05:37 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 5 Apr 2019 16:33:01 +0000 (17:33 +0100)
Enable the building of the curses based ui for cmake. This depends on
ncurses.

Signed-off-by: Nathan Rossi <nathan@nathanrossi.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/cmake/cmake-native_3.14.1.bb

index fedcf3d4bdb49400c4812852c9fddbe7f8bfd7d7..b2952ee5f577c50f7ccfbafc43eb0d0f4ab0d4b8 100644 (file)
@@ -1,7 +1,7 @@
 require cmake.inc
 inherit native
 
-DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native"
+DEPENDS += "bzip2-replacement-native expat-native xz-native zlib-native curl-native ncurses-native"
 
 SRC_URI += "file://OEToolchainConfig.cmake \
             file://environment.d-cmake.sh \
@@ -13,10 +13,9 @@ SRC_URI += "file://OEToolchainConfig.cmake \
 B = "${WORKDIR}/build"
 do_configure[cleandirs] = "${B}"
 
-# Disable ccmake since we don't depend on ncurses
 CMAKE_EXTRACONF = "\
     -DCMAKE_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
-    -DBUILD_CursesDialog=0 \
+    -DBUILD_CursesDialog=1 \
     -DCMAKE_USE_SYSTEM_LIBRARIES=1 \
     -DCMAKE_USE_SYSTEM_LIBRARY_JSONCPP=0 \
     -DCMAKE_USE_SYSTEM_LIBRARY_LIBARCHIVE=0 \