]> code.ossystems Code Review - openembedded-core.git/commitdiff
dtc: update to 1.4.7
authorAlexander Kanavin <alex.kanavin@gmail.com>
Thu, 6 Sep 2018 10:29:25 +0000 (12:29 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Sep 2018 22:43:34 +0000 (23:43 +0100)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/dtc/dtc/make_install.patch
meta/recipes-kernel/dtc/dtc_1.4.7.bb [moved from meta/recipes-kernel/dtc/dtc_1.4.6.bb with 81% similarity]

index ccf17b38fdb0691c229d91af8568f5bd94e86f23..ea9359e815ba3942f8d8a0c99622a421d32ff3a4 100644 (file)
@@ -1,17 +1,26 @@
+From e9852b9d206df1e42aa4c8afec55a0f5e099b533 Mon Sep 17 00:00:00 2001
+From: Saul Wold <sgw@linux.intel.com>
+Date: Thu, 3 Nov 2011 08:35:47 -0700
+Subject: [PATCH] dtc: Add patch to correctly install shared libraries and
+
 Upstream-Status: Inappropriate [configuration]
 
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile
-+++ git/Makefile
-@@ -168,8 +168,8 @@ install-bin: all $(SCRIPTS)
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d8ebc4f..f5e01be 100644
+--- a/Makefile
++++ b/Makefile
+@@ -205,8 +205,8 @@ install-bin: all $(SCRIPTS)
  install-lib: all
        @$(VECHO) INSTALL-LIB
        $(INSTALL) -d $(DESTDIR)$(LIBDIR)
--      $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)
+-      $(INSTALL_LIB) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)
 -      ln -sf $(notdir $(LIBFDT_lib)) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
 +      $(INSTALL) $(LIBFDT_lib) $(DESTDIR)$(LIBDIR)/$(LIBFDT_soname)
 +      ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/$(notdir $(LIBFDT_lib))
        ln -sf $(LIBFDT_soname) $(DESTDIR)$(LIBDIR)/libfdt.$(SHAREDLIB_EXT)
-       $(INSTALL) -m 644 $(LIBFDT_archive) $(DESTDIR)$(LIBDIR)
+       $(INSTALL_DATA) $(LIBFDT_archive) $(DESTDIR)$(LIBDIR)
  
similarity index 81%
rename from meta/recipes-kernel/dtc/dtc_1.4.6.bb
rename to meta/recipes-kernel/dtc/dtc_1.4.7.bb
index 78c57363926d0c85414e4cd879c1672f2c93debd..6ce462a7f49c06908a35cfbedba6aff9ea252857 100644 (file)
@@ -3,7 +3,7 @@ require dtc.inc
 LIC_FILES_CHKSUM = "file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
                    file://libfdt/libfdt.h;beginline=3;endline=52;md5=fb360963151f8ec2d6c06b055bcbb68c"
 
-SRCREV = "e54388015af1fb4bf04d0bca99caba1074d9cc42"
+SRCREV = "88f18909db731a627456f26d779445f84e449536"
 
 S = "${WORKDIR}/git"