]> code.ossystems Code Review - openembedded-core.git/commitdiff
gettext: Backport updated macros from gettext 0.17 to avoid conflicts with libtool
authorRichard Purdie <richard@openedhand.com>
Tue, 15 Apr 2008 14:23:12 +0000 (14:23 +0000)
committerRichard Purdie <richard@openedhand.com>
Tue, 15 Apr 2008 14:23:12 +0000 (14:23 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4272 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gettext/gettext-native_0.14.1.bb
meta/packages/gettext/gettext_0.14.1.bb

index 6203b1f9d7e762e327a4dce8d1db692263de22e7..37549dbdad2607a74cf9f0bedcff24b2817a3605 100644 (file)
@@ -50,4 +50,11 @@ do_stage_append() {
                fi
                install -m 0644 $src ${STAGING_DATADIR}/aclocal/$i
        done
+
+       # config.rpath is needed by some configure macros and needs to be autoinstalled.
+       # automake will do this but config.rpath needs to be visible to automake
+       for i in `ls -d ${STAGING_DATADIR}/automake*`
+       do
+               cp ${STAGING_DATADIR}/gettext/config.rpath $i
+       done                                                    
 }
index 7bc011f4947b7df079e29be704cd68b45ab956f8..5ad20596157672f1123295621bd3c06f58777bf7 100644 (file)
@@ -2,12 +2,13 @@ DESCRIPTION = "The GNU internationalization library."
 HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
 SECTION = "libs"
 LICENSE = "GPL"
-PR = "r8"
+PR = "r10"
 PROVIDES = "virtual/libintl"
 
 SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
           file://gettext-vpath.patch;patch=1;pnum=1 \
           file://fixchicken.patch;patch=1;pnum=1 \
+           file://linklib_from_0.17.patch;patch=1 \
            file://getline.m4.patch;patch=1 \
            file://disable_java.patch;patch=1"
 
@@ -30,4 +31,11 @@ do_configure_prepend() {
 
 do_stage () {
        autotools_stage_all
+
+       # config.rpath is needed by some configure macros and needs to be autoinstalled.
+       # automake will do this but config.rpath needs to be visible to automake
+       for i in `ls -d ${STAGING_DATADIR}/automake*`
+       do
+               cp ${STAGING_DATADIR}/gettext/config.rpath $i
+       done
 }