]> code.ossystems Code Review - openembedded-core.git/commitdiff
openssh: use tarballs instead of git
authorAlexander Kanavin <alex.kanavin@gmail.com>
Tue, 8 Jan 2019 15:25:29 +0000 (16:25 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 11 Jan 2019 10:29:37 +0000 (10:29 +0000)
This was change to git recently to obtain openssl 1.1 compatible pre-release code
(before 7.9 was out), however tarballs are preferred, and with them upstream version
checks work (openssh uses a weird git tag scheme).

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/openssh/openssh_7.9p1.bb [moved from meta/recipes-connectivity/openssh/openssh_7.9p1+git.bb with 96% similarity]

similarity index 96%
rename from meta/recipes-connectivity/openssh/openssh_7.9p1+git.bb
rename to meta/recipes-connectivity/openssh/openssh_7.9p1.bb
index d79ffe19710f1e5fbc48083b0081ea5db2bd5b78..2a23f64b894ecdbdddd6c42dbda663cca585dc22 100644 (file)
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=429658c6612f3a9b1293782366ab29d8"
 DEPENDS = "zlib openssl"
 DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
 
-SRC_URI = "git://github.com/openssh/openssh-portable;branch=master \
+SRC_URI = "http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
            file://sshd_config \
            file://ssh_config \
            file://init \
@@ -25,13 +25,11 @@ SRC_URI = "git://github.com/openssh/openssh-portable;branch=master \
            file://sshd_check_keys \
            file://add-test-support-for-busybox.patch \
            "
+SRC_URI[md5sum] = "c6af50b7a474d04726a5aa747a5dce8f"
+SRC_URI[sha256sum] = "6b4b3ba2253d84ed3771c8050728d597c91cfce898713beb7b64a305b6f11aad"
 
 PAM_SRC_URI = "file://sshd"
 
-SRCREV = "aede1c34243a6f7feae2fb2cb686ade5f9be6f3d"
-
-S = "${WORKDIR}/git"
-
 inherit useradd update-rc.d update-alternatives systemd
 
 USERADD_PACKAGES = "${PN}-sshd"