]> code.ossystems Code Review - openembedded-core.git/commitdiff
u-boot: Add support for building for qemuriscv32
authorAlistair Francis <alistair.francis@wdc.com>
Fri, 12 Mar 2021 21:38:25 +0000 (13:38 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 14 Mar 2021 16:33:03 +0000 (16:33 +0000)
Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/conf/machine/qemuriscv32.conf
meta/recipes-bsp/u-boot/files/0001-riscv32-Use-double-float-ABI-for-rv32.patch [new file with mode: 0644]
meta/recipes-bsp/u-boot/u-boot_2021.01.bb

index 1413775ad63c1134b937056b19f3c6177002544a..d3858dc05138b8a6cc4179f55bb52c0791ef0fd7 100644 (file)
@@ -11,7 +11,6 @@ PREFERRED_VERSION_openocd = "riscv"
 
 XVISOR_PLAT = "riscv/virt32"
 
-# u-boot doesn't compile, error: "can't link hard-float modules with soft-float modules"
-# EXTRA_IMAGEDEPENDS += "u-boot"
-# UBOOT_MACHINE = "qemu-riscv32_smode_defconfig"
-# UBOOT_ELF = "u-boot"
+EXTRA_IMAGEDEPENDS += "u-boot"
+UBOOT_MACHINE = "qemu-riscv32_smode_defconfig"
+UBOOT_ELF = "u-boot"
diff --git a/meta/recipes-bsp/u-boot/files/0001-riscv32-Use-double-float-ABI-for-rv32.patch b/meta/recipes-bsp/u-boot/files/0001-riscv32-Use-double-float-ABI-for-rv32.patch
new file mode 100644 (file)
index 0000000..0ed3de4
--- /dev/null
@@ -0,0 +1,42 @@
+From 66dfe0fa886f6289add06d1af8642ce2b5302852 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 9 Feb 2021 16:40:12 -0800
+Subject: [PATCH] riscv32: Use double-float ABI for rv32
+
+So it can use libgcc built with OE toolchain
+Fixes
+error: "can't link hard-float modules with soft-float modules"
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Inappropriate [embedded specific]
+---
+ arch/riscv/Makefile | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/arch/riscv/Makefile b/arch/riscv/Makefile
+index 0b80eb8d86..7324946f48 100644
+--- a/arch/riscv/Makefile
++++ b/arch/riscv/Makefile
+@@ -9,7 +9,9 @@ ifeq ($(CONFIG_ARCH_RV64I),y)
+ endif
+ ifeq ($(CONFIG_ARCH_RV32I),y)
+       ARCH_BASE = rv32im
+-      ABI = ilp32
++      ABI = ilp32d
++      ARCH_D = d
++      ARCH_F = f
+ endif
+ ifeq ($(CONFIG_RISCV_ISA_A),y)
+       ARCH_A = a
+@@ -24,7 +26,7 @@ ifeq ($(CONFIG_CMODEL_MEDANY),y)
+       CMODEL = medany
+ endif
+-ARCH_FLAGS = -march=$(ARCH_BASE)$(ARCH_A)$(ARCH_C) -mabi=$(ABI) \
++ARCH_FLAGS = -march=$(ARCH_BASE)$(ARCH_A)$(ARCH_F)$(ARCH_D)$(ARCH_C) -mabi=$(ABI) \
+            -mcmodel=$(CMODEL)
+ PLATFORM_CPPFLAGS     += $(ARCH_FLAGS)
+-- 
+2.30.0
+
index 2eef1e900eb349e97cd71937971cab6de9af8533..bbbc99bf8d1d2f67e1e28894c8b48238341fbd43 100644 (file)
@@ -1,4 +1,6 @@
 require u-boot-common.inc
 require u-boot.inc
 
+SRC_URI_append = " file://0001-riscv32-Use-double-float-ABI-for-rv32.patch"
+
 DEPENDS += "bc-native dtc-native python3-setuptools-native"