]> code.ossystems Code Review - openembedded-core.git/commitdiff
Disable the Handed option for now
authorRoss Burton <ross@openedhand.com>
Fri, 27 Jul 2007 09:43:21 +0000 (09:43 +0000)
committerRoss Burton <ross@openedhand.com>
Fri, 27 Jul 2007 09:43:21 +0000 (09:43 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2236 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/matchbox-config-gtk/files/no-handed.patch [new file with mode: 0644]
meta/packages/matchbox-config-gtk/matchbox-config-gtk_svn.bb

diff --git a/meta/packages/matchbox-config-gtk/files/no-handed.patch b/meta/packages/matchbox-config-gtk/files/no-handed.patch
new file mode 100644 (file)
index 0000000..91b27ae
--- /dev/null
@@ -0,0 +1,33 @@
+Index: matchbox-config-gtk/appearance/mb-appearance.c
+===================================================================
+--- matchbox-config-gtk/appearance/mb-appearance.c     (revision 1614)
++++ matchbox-config-gtk/appearance/mb-appearance.c     (working copy)
+@@ -300,11 +300,13 @@
+     gtk_font_button_set_font_name (GTK_FONT_BUTTON (font_button),
+                                    gconf_value_get_string (value));
+   } else if (strcmp (key, HANDED_KEY) == 0) {
++#if 0
+     GEnumValue *e;
+     e = g_enum_get_value_by_name (g_type_class_ref (GTK_TYPE_CORNER_TYPE),
+                                   gconf_value_get_string (value));
+     gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (handed_check),
+                                   e->value == GTK_CORNER_TOP_RIGHT);
++#endif
+   }
+ }
+@@ -395,12 +397,13 @@
+   gtk_container_add (GTK_CONTAINER (align), font_button);
+   /* Left/Right Handed */
+-  
++#if 0
+   frame = new_frame (_("Orientation"), &align);
+   gtk_box_pack_start (GTK_BOX (box), frame, TRUE, TRUE, 0);
+   handed_check = gtk_check_button_new_with_mnemonic (_("_Left-handed"));
+   g_signal_connect (handed_check, "toggled", G_CALLBACK (on_handed_set), NULL);
+   gtk_container_add (GTK_CONTAINER (align), handed_check);
++#endif
+   gconf_client_add_dir (gconf, INTERFACE_DIR, GCONF_CLIENT_PRELOAD_ONELEVEL, NULL);
+   g_signal_connect (gconf, "value-changed", G_CALLBACK (on_gconf_value_changed), NULL);
index ec11e45ad78ad3ef430bf5a187e354588e69e3d3..0e9100666133a225a96de4952feb5af30efae16c 100644 (file)
@@ -1,11 +1,15 @@
-DESCRIPTION = "Matchbox gtk theme configuration application."
+DESCRIPTION = "Matchbox GTK+ theme configuration application."
 LICENSE = "GPL"
-DEPENDS = "gconf libglade gtk+"
+DEPENDS = "gconf gtk+"
 RDEPENDS = "settings-daemon"
+
 PV = "0.0+svn${SRCDATE}"
+PR = "r1"
+
 S = "${WORKDIR}/${PN}"
 
-SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
+        file://no-handed.patch;patch=1;pnum=0"
 
 inherit autotools pkgconfig