]> code.ossystems Code Review - openembedded-core.git/commitdiff
createrepo: fix native binary
authorQing He <qing.he@intel.com>
Mon, 31 Jan 2011 08:49:39 +0000 (16:49 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 31 Jan 2011 16:27:14 +0000 (16:27 +0000)
Signed-off-by: Qing He <qing.he@intel.com>
meta/recipes-support/createrepo/createrepo/fix-native-install.patch
meta/recipes-support/createrepo/createrepo_0.4.11.bb

index f17d224d1f1c85b46dcff39fb88b926df108f3fd..2ed2202e7790df6812b1abc68aa42582d6a46065 100644 (file)
@@ -1,3 +1,11 @@
+Date: Jan 31, 2011
+
+There are two fixes:
+  1. -native needs to customize prefix
+  2. needs to change python reference in binaries
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
 diff --git a/Makefile b/Makefile
 index b2d1a32..3c3639f 100644
 --- a/Makefile
@@ -40,7 +48,7 @@ index b2d1a32..3c3639f 100644
  pkgdatadir = $(datadir)/$(PACKAGE)
  pkglibdir = $(libdir)/$(PACKAGE)
 diff --git a/bin/Makefile b/bin/Makefile
-index 52c1f50..abef96a 100644
+index 52c1f50..e30610e 100644
 --- a/bin/Makefile
 +++ b/bin/Makefile
 @@ -1,22 +1,22 @@
@@ -80,6 +88,36 @@ index 52c1f50..abef96a 100644
  
  pkgdatadir = $(datadir)/$(PACKAGE)
  pkglibdir = $(libdir)/$(PACKAGE)
+@@ -40,8 +40,11 @@ all: $(srcdir)/$(PACKAGE)
+ install: all installdirs
+-      $(INSTALL_BIN) $(srcdir)/$(PACKAGE) $(DESTDIR)$(bindir)/$(PACKAGE)
+-      $(INSTALL_BIN) $(srcdir)/modifyrepo $(DESTDIR)$(bindir)/modifyrepo
++      sed -e "s|@DATADIR@|$(datadir)|" $(srcdir)/$(PACKAGE) > $(srcdir)/$(PACKAGE).tmp
++      sed -e "s|@DATADIR@|$(datadir)|" $(srcdir)/modifyrepo > $(srcdir)/modifyrepo.tmp
++      $(INSTALL_BIN) $(srcdir)/$(PACKAGE).tmp $(DESTDIR)$(bindir)/$(PACKAGE)
++      $(INSTALL_BIN) $(srcdir)/modifyrepo.tmp $(DESTDIR)$(bindir)/modifyrepo
++      rm -f $(srcdir)/$(PACKAGE).tmp $(srcdir)/modifyrepo.tmp
+ uninstall:
+diff --git a/bin/createrepo b/bin/createrepo
+index b0de515..eaacb39 100755
+--- a/bin/createrepo
++++ b/bin/createrepo
+@@ -1,2 +1,2 @@
+ #!/bin/sh
+-exec /usr/share/createrepo/genpkgmetadata.py "$@"
++exec @DATADIR@/createrepo/genpkgmetadata.py "$@"
+diff --git a/bin/modifyrepo b/bin/modifyrepo
+index c9732d8..6f7c1d4 100755
+--- a/bin/modifyrepo
++++ b/bin/modifyrepo
+@@ -1,2 +1,2 @@
+ #!/bin/sh
+-exec /usr/share/createrepo/modifyrepo.py "$@"
++exec @DATADIR@/createrepo/modifyrepo.py "$@"
 diff --git a/docs/Makefile b/docs/Makefile
 index 0a41179..e128c85 100644
 --- a/docs/Makefile
index 62cf7787066c4ffcb0c02b0a61627c98d2a928c6..ba1d04b2bde1eff627d9a50e82b85d1064f9c28c 100644 (file)
@@ -4,7 +4,7 @@ HOMEPAGE = "http://createrepo.baseurl.org/"
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI= "http://createrepo.baseurl.org/download/${BP}.tar.gz \
           file://fix-native-install.patch \