]> code.ossystems Code Review - openembedded-core.git/commitdiff
gcc: gcc-cross-canadian: use correct location for libraries for powerpc64
authorMatthew McClintock <msm@freescale.com>
Tue, 10 Jul 2012 04:29:22 +0000 (04:29 +0000)
committerScott Garman <scott.a.garman@intel.com>
Wed, 18 Jul 2012 17:18:53 +0000 (10:18 -0700)
This fixes the issue where gcc invokes the linker with an incorrect -L
library location and gives up because it can't find libraries. It was
looking in a /lib folder instead of /lib64

Signed-off-by: Matthew McClintock <msm@freescale.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/gcc/gcc-4.6.inc
meta/recipes-devtools/gcc/gcc-cross-canadian_4.6.bb

index 32545ebe4165f6bd4afeb15b6d6b2fcc5d12b089..c71312e89272158a656c859a8aa06d348b688008 100644 (file)
@@ -1,6 +1,6 @@
 require gcc-common.inc
 
-PR = "r26"
+PR = "r27"
 
 # Third digit in PV should be incremented after a minor release
 # happens from this branch on gcc e.g. currently its 4.6.0
index da3210fc3511f0c457ca70767740ea032b0e4b44..74f983dd33dbdda9b48e7bc3f0acfc424dab2583 100644 (file)
@@ -9,8 +9,8 @@ DEPENDS += "gmp-nativesdk mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
 RDEPENDS_${PN} += "mpfr-nativesdk libmpc-nativesdk elfutils-nativesdk"
 
 SYSTEMHEADERS = "/usr/include"
-SYSTEMLIBS = "/lib/"
-SYSTEMLIBS1 = "/usr/lib/"
+SYSTEMLIBS = "${target_base_libdir}/"
+SYSTEMLIBS1 = "${target_libdir}/"
 
 EXTRA_OECONF += "--disable-libunwind-exceptions --disable-libssp \
                --disable-libgomp --disable-libmudflap \