]> code.ossystems Code Review - openembedded-core.git/commitdiff
mdadm: Fix gcc 6 warnings
authorKhem Raj <raj.khem@gmail.com>
Wed, 11 May 2016 17:35:13 +0000 (10:35 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 13 May 2016 12:40:51 +0000 (13:40 +0100)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-extended/mdadm/files/0001-raid6check-Fix-if-else-indentation.patch [new file with mode: 0644]
meta/recipes-extended/mdadm/mdadm_3.4.bb

diff --git a/meta/recipes-extended/mdadm/files/0001-raid6check-Fix-if-else-indentation.patch b/meta/recipes-extended/mdadm/files/0001-raid6check-Fix-if-else-indentation.patch
new file mode 100644 (file)
index 0000000..0b34b84
--- /dev/null
@@ -0,0 +1,37 @@
+From 1b0aa1debf6fbe9923c9aac671d2894f76c32f9d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 20 Apr 2016 16:38:13 +0000
+Subject: [PATCH] raid6check: Fix if-else indentation
+
+gcc 6 warns about ambiguity due to this indentation
+| raid6check.c: In function 'manual_repair':
+| raid6check.c:267:4: error: this 'else' clause does not guard... [-Werror=misleading-indentation]
+|     else
+|     ^~~~
+| raid6check.c:269:5: note: ...this statement, but the latter is misleadingly indented as if it is guarded by the 'else'
+|      printf("Repairing D(%d) and P\n", failed_data);
+|      ^~~~~~
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Submitted
+
+ raid6check.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/raid6check.c b/raid6check.c
+index ad7ffe7..409b1b6 100644
+--- a/raid6check.c
++++ b/raid6check.c
+@@ -266,7 +266,7 @@ int manual_repair(int chunk_size, int syndrome_disks,
+                               failed_data = failed_slot2;
+                       else
+                               failed_data = failed_slot1;
+-                              printf("Repairing D(%d) and P\n", failed_data);
++                      printf("Repairing D(%d) and P\n", failed_data);
+                       raid6_datap_recov(syndrome_disks+2, chunk_size,
+                                         failed_data, (uint8_t**)blocks, 1);
+               } else {
+-- 
+1.9.1
+
index 142dfddbf245d19d012f695a8c849fcb14a22d4e..0e55de44505afff348df82cee8a8ec95fe581776 100644 (file)
@@ -19,7 +19,8 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
            file://0001-Fix-some-type-comparison-problems.patch \
            file://0001-Fix-the-path-of-corosync-and-dlm-header-files-check.patch \
            file://run-ptest \
-         "
+           file://0001-raid6check-Fix-if-else-indentation.patch \
+           "
 SRC_URI[md5sum] = "04b8b21f637540350f8517c7e68d3c63"
 SRC_URI[sha256sum] = "27d0be4627d38a12ddcd1c1c3721d649d4e89e1093914497e22b57245cda8808"