]> code.ossystems Code Review - openembedded-core.git/commitdiff
telepathy-python: fix build with automake 1.12
authorNitin A Kamble <nitin.a.kamble@intel.com>
Tue, 10 Jul 2012 09:29:38 +0000 (02:29 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 17 Jul 2012 09:47:31 +0000 (10:47 +0100)
Added a new patch:
telepathy-python_fix_for_automake_1.12.patch

More comments in the patch header.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch [new file with mode: 0644]
meta/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb

diff --git a/meta/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch b/meta/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch
new file mode 100644 (file)
index 0000000..f613fdc
--- /dev/null
@@ -0,0 +1,26 @@
+Upstream-Status: Pending
+
+automake 1.12 has deprecated use of mkdir_p, and it recommends
+use of MKDIR_P instead. Changed the code to avoid these kind 
+of warning-errors.
+
+| make[1]: _generated/: Command not found
+| make[1]: *** [_generated/__init__.py] Error 127
+| make[1]: Leaving directory `/srv/home/nitin/builds2/build0/tmp/work/i586-poky-linux/telepathy-python-0.15.19-r4/telepathy-python-0.15.19/src'
+| make: *** [all-recursive] Error 1
+
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+2012/07/10
+Index: telepathy-python-0.15.19/src/Makefile.am
+===================================================================
+--- telepathy-python-0.15.19.orig/src/Makefile.am
++++ telepathy-python-0.15.19/src/Makefile.am
+@@ -55,7 +55,7 @@ _generated/errors.py: _generated/__init_
+           $(spec_dir)/all.xml
+ _generated/__init__.py:
+-      $(AM_V_GEN)$(mkdir_p) $(dir $@)
++      $(AM_V_GEN)$(MKDIR_P) $(dir $@)
+       @echo "# Placeholder for package" > $@
+ _generated/%.py: _generated/__init__.py $(tools_dir)/spec-to-python.xsl $(spec_dir)/%.xml
index 0113854d961d2a95c593f208d17b2dcdf5ba4681..383e29ab10bbc01822ae4c24207697be72aba41b 100644 (file)
@@ -8,9 +8,10 @@ RDEPENDS_${PN} += "python-dbus"
 
 SRC_URI = "http://telepathy.freedesktop.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
            file://parallel_make.patch \
-           file://remove_duplicate_install.patch"
+           file://remove_duplicate_install.patch \
+           file://telepathy-python_fix_for_automake_1.12.patch"
 
-PR = "r4"
+PR = "r5"
 
 inherit autotools