]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd-bootchart: Add mips64 tuples
authorKhem Raj <raj.khem@gmail.com>
Tue, 17 Dec 2019 03:47:07 +0000 (19:47 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 28 Dec 2019 23:25:34 +0000 (23:25 +0000)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-devtools/systemd-bootchart/systemd-bootchart/mips64.patch [new file with mode: 0644]
meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb

diff --git a/meta/recipes-devtools/systemd-bootchart/systemd-bootchart/mips64.patch b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart/mips64.patch
new file mode 100644 (file)
index 0000000..6206bc4
--- /dev/null
@@ -0,0 +1,35 @@
+Recognise mips64 n32/n64
+
+These are supported in systemd now a days
+
+Upstream-Status: Backport [https://github.com/systemd/systemd/commit/caf49b95b3a6efe9455078098c729d83b08e5206]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/src/architecture.h
++++ b/src/architecture.h
+@@ -127,13 +127,22 @@ int uname_architecture(void);
+ #  define native_architecture() ARCHITECTURE_SPARC
+ #  define LIB_ARCH_TUPLE "sparc-linux-gnu"
+ #  define PROC_CPUINFO_MODEL "cpu"
+-#elif defined(__mips64__)
++#elif defined(__mips64) && defined(__LP64__)
+ #  if __BYTE_ORDER == __BIG_ENDIAN
+ #    define native_architecture() ARCHITECTURE_MIPS64
+-#    error "Missing LIB_ARCH_TUPLE for MIPS64"
++#    define LIB_ARCH_TUPLE "mips64-linux-gnuabi64"
+ #  else
+ #    define native_architecture() ARCHITECTURE_MIPS64_LE
+-#    error "Missing LIB_ARCH_TUPLE for MIPS64_LE"
++#    define LIB_ARCH_TUPLE "mips64el-linux-gnuabi64"
++#  endif
++#  define PROC_CPUINFO_MODEL "cpu model"
++#elif defined(__mips64)
++#  if __BYTE_ORDER == __BIG_ENDIAN
++#    define native_architecture() ARCHITECTURE_MIPS64
++#    define LIB_ARCH_TUPLE "mips64-linux-gnuabin32"
++#  else
++#    define native_architecture() ARCHITECTURE_MIPS64_LE
++#    define LIB_ARCH_TUPLE "mips64el-linux-gnuabin32"
+ #  endif
+ #  define PROC_CPUINFO_MODEL "cpu model"
+ #elif defined(__mips__)
index 960edc75e6f30c9d13415e3433286e039c5b2a39..a7a1f0ff1a5f61835dce10c2c840ce7a08c1ec15 100644 (file)
@@ -4,6 +4,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c
 
 SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https \
            file://0001-architecture-Recognise-RISCV-32-RISCV-64.patch \
+           file://mips64.patch \
 "
 
 SRC_URI_append_libc-musl = " \