]> code.ossystems Code Review - openembedded-core.git/commitdiff
dnf, libdnf: Ignore if PACKAGE_CLASSES does not have rpm
authorKhem Raj <raj.khem@gmail.com>
Thu, 20 Feb 2020 21:09:52 +0000 (13:09 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 21 Feb 2020 17:46:46 +0000 (17:46 +0000)
dnf depends on libsolv, and libsolv does not have and easy way to
jusr enable rpmdb support, it either has full rpm or nothing, perhaps it
could be improved in libsolv and we can use that but from now we have
no other option

dnf support only rpm backend and wont work with opkg or dpkg/apt anyway

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/dnf/dnf_4.2.2.bb
meta/recipes-devtools/libdnf/libdnf_0.28.1.bb

index f38167f1ad090f325d31ead95ac738861f5a19fd..f6e616e7f19cdce831ed16af97166e3cf6069eeb 100644 (file)
@@ -84,3 +84,5 @@ SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
                          dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \
 "
 SYSTEMD_AUTO_ENABLE ?= "disable"
+
+PNBLACKLIST[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"
index 882c435b32b425a532e9513d8e2d38e9200603f2..d4983470946cbfef42ee15393969076777d8f611 100644 (file)
@@ -26,4 +26,5 @@ EXTRA_OECMAKE_append_class-native = " -DWITH_GIR=OFF"
 EXTRA_OECMAKE_append_class-nativesdk = " -DWITH_GIR=OFF"
 
 BBCLASSEXTEND = "native nativesdk"
+PNBLACKLIST[libdnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'Does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"