]> code.ossystems Code Review - openembedded-core.git/commitdiff
task-core-tools: Exclude systemtap for uclibc
authorKhem Raj <raj.khem@gmail.com>
Tue, 19 Jul 2011 20:56:54 +0000 (13:56 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 20 Jul 2011 14:25:02 +0000 (15:25 +0100)
systemtap needs full fledged elfutils which cant be
built on uclibc therefore we live without systemtap
on uclibc

Signed-off-by: Khem Raj <raj.khem@gmail.com>
meta/recipes-core/tasks/task-core-tools.bb

index 44520a75c7aa80b8f883bfc656e6686f480a5e55..eed4afb69ea8b37d1813a0b88dea5a54df43c310 100644 (file)
@@ -53,6 +53,11 @@ RRECOMMENDS_task-core-tools-profile = "\
     sysprof \
     "
 
+# systemtap needs elfutils which is not fully buildable on uclibc
+# hence we exclude it from uclibc based builds
+SYSTEMTAP = "systemtap"
+SYSTEMTAP_libc-uclibc = ""
+
 #    exmap-console
 #    exmap-server
 
@@ -60,9 +65,9 @@ RRECOMMENDS_task-core-tools-profile = "\
 # qemux86/qemux86-64/qemuppc/qemuarm/emenlow/atom-pc since upstream liburcu
 # (which is required by lttng-ust) may not build on other platforms, like
 # MIPS.
-RDEPENDS_task-core-tools-profile_append_qemux86 = " valgrind lttng-ust systemtap"
-RDEPENDS_task-core-tools-profile_append_qemux86-64 = " lttng-ust systemtap"
-RDEPENDS_task-core-tools-profile_append_qemuppc = " lttng-ust systemtap"
+RDEPENDS_task-core-tools-profile_append_qemux86 = " valgrind lttng-ust ${SYSTEMTAP}"
+RDEPENDS_task-core-tools-profile_append_qemux86-64 = " lttng-ust ${SYSTEMTAP}"
+RDEPENDS_task-core-tools-profile_append_qemuppc = " lttng-ust ${SYSTEMTAP}"
 RDEPENDS_task-core-tools-profile_append_qemuarm = " lttng-ust"
 
 RDEPENDS_task-core-tools-testapps = "\