]> code.ossystems Code Review - openembedded-core.git/commitdiff
tzcode-native: update to 2015e
authorArmin Kuster <akuster808@gmail.com>
Sun, 14 Jun 2015 05:03:41 +0000 (22:03 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 18 Jun 2015 08:12:01 +0000 (09:12 +0100)
merged inc back into recipe.

Changes affecting code

When displaying data, tzselect converts it to the current locale's
encoding if the iconv command works.  (Problem reported by random832.)

tzselect no longer mishandles Dominica, fixing a bug introduced
in Release 2014f.  (Problem reported by Owen Leibman.)

zic -l no longer fails when compiled with -DTZDEFAULT=\"/etc/localtime\".
This fixes a bug introduced in Release 2014f.
(Problem reported by Leonardo Chiquitto.)

Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/tzcode/tzcode-native.inc [deleted file]
meta/recipes-extended/tzcode/tzcode-native_2015d.bb [deleted file]
meta/recipes-extended/tzcode/tzcode-native_2015e.bb [new file with mode: 0644]

diff --git a/meta/recipes-extended/tzcode/tzcode-native.inc b/meta/recipes-extended/tzcode/tzcode-native.inc
deleted file mode 100644 (file)
index 4af1e20..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
-LICENSE = "PD & BSD"
-
-LIC_FILES_CHKSUM = "file://${WORKDIR}/README;md5=d0ff93a73dd5bc3c6e724bb4343760f6"
-
-S = "${WORKDIR}"
-
-inherit native
-
-do_install () {
-        install -d ${D}${bindir}/
-        install -m 755 zic ${D}${bindir}/
-        install -m 755 zdump ${D}${bindir}/
-        install -m 755 tzselect ${D}${bindir}/
-}
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2015d.bb b/meta/recipes-extended/tzcode/tzcode-native_2015d.bb
deleted file mode 100644 (file)
index 44a9f03..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-# note that we allow for us to use data later than our code version
-#
-SRC_URI =" ftp://ftp.iana.org/tz/releases/tzcode${PV}.tar.gz;name=tzcode \
-           ftp://ftp.iana.org/tz/releases/tzdata2015d.tar.gz;name=tzdata"
-
-SRC_URI[tzcode.md5sum] = "4008a3abc025a398697b2587c48258b9"
-SRC_URI[tzcode.sha256sum] = "221af54ec5c42eaf0101159ffe1256a883d1c14c46228d42774c656a56317128"
-SRC_URI[tzdata.md5sum] = "b595bdc4474b8fc1a15cffc67c66025b"
-SRC_URI[tzdata.sha256sum] = "8b9f5008277f09e251e97dba7813f56168d691115bda90ade4638d72f296d531"
-
-require tzcode-native.inc
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2015e.bb b/meta/recipes-extended/tzcode/tzcode-native_2015e.bb
new file mode 100644 (file)
index 0000000..30dba7a
--- /dev/null
@@ -0,0 +1,25 @@
+# note that we allow for us to use data later than our code version
+#
+DESCRIPTION = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
+LICENSE = "PD & BSD"
+
+LIC_FILES_CHKSUM = "file://${WORKDIR}/README;md5=d0ff93a73dd5bc3c6e724bb4343760f6"
+
+SRC_URI =" ftp://ftp.iana.org/tz/releases/tzcode${PV}.tar.gz;name=tzcode \
+           ftp://ftp.iana.org/tz/releases/tzdata2015e.tar.gz;name=tzdata"
+
+SRC_URI[tzcode.md5sum] = "fb62eb6daf3ddb8c41fd40be05ec657e"
+SRC_URI[tzcode.sha256sum] = "b5a217b55847fb56f470a7738939c36f3a520d6cc12342d965cfcf848e59ada0"
+SRC_URI[tzdata.md5sum] = "36f9056efb432ca945c73397acfce0d4"
+SRC_URI[tzdata.sha256sum] = "ffc9b5d38abda8277aa479e3f75aa7668819d0977cd1a0c8ef3b09128334ba6f"
+
+S = "${WORKDIR}"
+
+inherit native
+
+do_install () {
+        install -d ${D}${bindir}/
+        install -m 755 zic ${D}${bindir}/
+        install -m 755 zdump ${D}${bindir}/
+        install -m 755 tzselect ${D}${bindir}/
+}