]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml-simple-perl: Use BBCLASSEXTEND insteand of *-native recipe
authorDongxiao Xu <dongxiao.xu@intel.com>
Wed, 3 Aug 2011 15:19:34 +0000 (23:19 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 3 Aug 2011 17:05:32 +0000 (18:05 +0100)
It's not appropriate to require xxx.bb in xxx-native.bb, causing that
xxx-native depends on target recipe.

Use BBCLASSEXTEND to solve this issue.

Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/libxml-simple-perl-native_2.18.bb [deleted file]
meta/recipes-devtools/perl/libxml-simple-perl_2.18.bb

diff --git a/meta/recipes-devtools/perl/libxml-simple-perl-native_2.18.bb b/meta/recipes-devtools/perl/libxml-simple-perl-native_2.18.bb
deleted file mode 100644 (file)
index 3877d0b..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-SECTION = "libs"
-
-inherit native
-
-require libxml-simple-perl_${PV}.bb
-
-DEPENDS += "libxml-parser-perl-native"
index 3a50d7f1d25a05e13803a6143ee10a2f7c64f49e..f2abf9dff9da6bd907fee55529d7b0a2c1ead3d0 100644 (file)
@@ -14,3 +14,5 @@ S = "${WORKDIR}/XML-Simple-${PV}"
 EXTRA_PERLFLAGS = "-I ${STAGING_LIBDIR_NATIVE}/perl-native/perl/${@get_perl_version(d)}"
 
 inherit cpan
+
+BBCLASSEXTEND = "native"