]> code.ossystems Code Review - openembedded-core.git/commitdiff
core-image-minimal: do not remove packaging files in the rootfs postprocess
authorLaurentiu Palcu <laurentiu.palcu@intel.com>
Tue, 21 May 2013 11:02:01 +0000 (14:02 +0300)
committerSaul Wold <sgw@linux.intel.com>
Mon, 10 Jun 2013 21:51:29 +0000 (14:51 -0700)
Since the removal of PM's meta-data was moved in image.bbclass, after
rootfs_*_do_rootfs() runs, there's no need to remove the files in rootfs
postprocess stage. Also, if the meta-data is removed then there's no way
we can save the postinstalls to /etc/(deb|ipk)-postinsts later.

For RPM, it doesn't really matter since the postinstalls are saved to
/etc/rpm-postinsts as soon as the postinstall fails.

[YOCTO #4484]

Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-core/images/core-image-minimal.bb

index 0d2613e32799cb31d7ee3f8dc548fc7dff7cf90e..0b56cc8549be05ce9b170cdee74993514c1ce6df 100644 (file)
@@ -10,5 +10,3 @@ inherit core-image
 
 IMAGE_ROOTFS_SIZE = "8192"
 
-# remove not needed ipkg informations
-ROOTFS_POSTPROCESS_COMMAND += "remove_packaging_data_files ; "