]> code.ossystems Code Review - openembedded-core.git/commitdiff
dhcp: package /var/lib/dhcp with dhcp-client rather than dhcp-server
authorSteve Sakoman <steve@sakoman.com>
Sat, 7 Jan 2012 04:51:54 +0000 (20:51 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 16 Jan 2012 12:24:31 +0000 (12:24 +0000)
Otherwise dhclient encounters errors of this type:

dhclient: can't create /var/lib/dhcp/dhclient-c0c60402-0bc5-4bd7-bc3b-49a27fa37d72-eth1.lease: No such file or directory

Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-connectivity/dhcp/dhcp.inc
meta/recipes-connectivity/dhcp/dhcp_4.2.0.bb

index f9d80e7831579a86150d6a8920ece44bb66b32ca..be256ce2807e20ef2f0c2a1ec975f234ff9a5570 100644 (file)
@@ -59,14 +59,14 @@ PACKAGES += "dhcp-server dhcp-server-config dhcp-client dhcp-relay dhcp-omshell"
 
 FILES_${PN} = ""
 
-FILES_dhcp-server = "${sbindir}/dhcpd ${sysconfdir}/init.d/dhcp-server ${localstatedir}/lib/dhcp/"
+FILES_dhcp-server = "${sbindir}/dhcpd ${sysconfdir}/init.d/dhcp-server"
 RRECOMMENDS_dhcp-server = "dhcp-server-config"
 
 FILES_dhcp-server-config = "${sysconfdir}/default/dhcp-server ${sysconfdir}/dhcp/dhcpd.conf"
 
 FILES_dhcp-relay = "${sbindir}/dhcrelay ${sysconfdir}/init.d/dhcp-relay ${sysconfdir}/default/dhcp-relay"
 
-FILES_dhcp-client = "${base_sbindir}/dhclient ${base_sbindir}/dhclient-script ${sysconfdir}/dhcp/dhclient.conf"
+FILES_dhcp-client = "${base_sbindir}/dhclient ${base_sbindir}/dhclient-script ${sysconfdir}/dhcp/dhclient.conf ${localstatedir}/lib/dhcp/"
 RDEPENDS_dhcp-client = "bash"
 
 FILES_dhcp-omshell = "${bindir}/omshell"
index 2471d6104460bf2ed4fcb180583fe5bf10280fe9..a3a560b99136d31bfcca0e0221019572a7469635 100644 (file)
@@ -1,6 +1,6 @@
 require dhcp.inc
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI += "file://fixincludes.patch \
             file://dhcp-3.0.3-dhclient-dbus.patch;striplevel=0 \