]> code.ossystems Code Review - openembedded-core.git/commitdiff
lsb: update i586 TARGET_ARCH tests to also handle i686
authorAndre McCurdy <armccurdy@gmail.com>
Tue, 30 Jun 2015 22:28:49 +0000 (15:28 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 7 Jul 2015 22:57:12 +0000 (23:57 +0100)
Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/lsb/lsb_4.1.bb
meta/recipes-extended/lsb/lsbtest_1.0.bb

index 7b2ee78e724e41182be1144593618ec0ea9ace18..6215b62d80070115cecf5412a04f0d7c8b7fb797 100644 (file)
@@ -40,7 +40,7 @@ do_install(){
        mkdir -p ${D}${sysconfdir}/lsb-release.d
        printf "LSB_VERSION=\"core-4.1-noarch:" > ${D}${sysconfdir}/lsb-release
 
-       if [ "${TARGET_ARCH}" = "i586" ];then
+       if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then
                printf "core-4.1-ia32" >>  ${D}${sysconfdir}/lsb-release
        else
                printf "core-4.1-${TARGET_ARCH}" >>  ${D}${sysconfdir}/lsb-release
@@ -53,7 +53,7 @@ do_install(){
        fi
        echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}${sysconfdir}/lsb-release
 
-       if [ "${TARGET_ARCH}" = "i586" ];then
+       if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then
                mkdir -p ${D}${sysconfdir}/lsb-release.d
                touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch
                touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-noarch
@@ -99,7 +99,7 @@ do_install_append(){
                ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.2
                ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.3
        fi
-       if [ "${TARGET_ARCH}" = "i586" ];then
+       if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then
               cd ${D}/${baselib}
                ln -sf ld-linux.so.2 ld-lsb.so.2
                ln -sf ld-linux.so.2 ld-lsb.so.3
index f61251e2aa026748185d0693eb4c2d9c839d8061..ea12502dc8831f839c29499aa19954181cf5c0b9 100644 (file)
@@ -19,7 +19,7 @@ do_install() {
        install -d  ${D}/opt/lsb-test
        install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list
        install -m 0644 ${S}/session ${D}/opt/lsb-test/session
-       if [ "${TARGET_ARCH}" = "i586" ];then
+       if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then
                sed -i -e 's/lsbarch/ia32/g' -e 's/targetarch/i486/g' ${D}/opt/lsb-test/packages_list
                sed -i -e 's/targetarch/x86/g' ${D}/opt/lsb-test/session
        fi