]> code.ossystems Code Review - openembedded-core.git/commitdiff
Change do_install logic to clean unwanted files better
authorRoss Burton <ross@openedhand.com>
Wed, 8 Aug 2007 11:18:40 +0000 (11:18 +0000)
committerRoss Burton <ross@openedhand.com>
Wed, 8 Aug 2007 11:18:40 +0000 (11:18 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2387 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb

index dcbea4a2ee05e21e7968f6f6c60b32d3f080d435..80ba7002d8b072f3b2828308b5fbc39357f8793d 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Common X11 scripts"
 LICENSE = "GPL"
 SECTION = "x11"
 RDEPENDS_${PN} = "xmodmap libxrandr xdpyinfo xtscal xinit formfactor"
-PR = "r18"
+PR = "r19"
 
 SRC_URI = "file://etc"
 S = ${WORKDIR}
@@ -11,8 +11,7 @@ PACKAGE_ARCH = "all"
 
 do_install() {
        cp -R ${S}/etc ${D}/etc
-       rm -fR ${D}/etc/.svn
-       rm -fR ${D}/etc/*/.svn
-       rm -fR ${D}/etc/*/*/.svn
        chmod -R 755 ${D}/etc
+       find ${D}/etc -type d -name .svn -prune -exec rm -rf {} \;
+       find ${D}/etc -type f -name \*~ -exec rm -rf {} \;
 }