]> code.ossystems Code Review - openembedded-core.git/commitdiff
xserver-nodm-init: use ${sysconfdir} instead of /etc for packaging
authorJavier Martinez Canillas <javier@dowhile0.org>
Sun, 5 Aug 2012 19:48:50 +0000 (21:48 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 6 Aug 2012 13:37:53 +0000 (14:37 +0100)
It is considered good practice to use the build system provided
variables instead of directly specify hardcoded paths.

Signed-off-by: Javier Martinez Canillas <javier@dowhile0.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/x11-common/xserver-nodm-init.bb

index 8fca05613cd2114b0f157bad43b5a410c595b798..eab76c597b54c1a7b217ee69e8ef6595eb8af634 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Simple Xserver Init Script (no dm)"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 SECTION = "x11"
-PR = "r29"
+PR = "r30"
 RDEPENDS_${PN} = "sudo"
 
 SRC_URI = "file://xserver-nodm \
@@ -14,12 +14,12 @@ S = "${WORKDIR}"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 do_install() {
-    install -d ${D}/etc
-    install -d ${D}/etc/init.d
-    install xserver-nodm ${D}/etc/init.d
+    install -d ${D}${sysconfdir}
+    install -d ${D}${sysconfdir}/init.d
+    install xserver-nodm ${D}${sysconfdir}/init.d
     if [ "${ROOTLESS_X}" = "1" ] ; then
-        install -d ${D}/etc/X11
-        install Xusername ${D}/etc/X11
+        install -d ${D}${sysconfdir}/X11
+        install Xusername ${D}${sysconfdir}/X11
     fi
 }