]> code.ossystems Code Review - openembedded-core.git/commitdiff
curl: support mqtt in PACKAGECONFIG
authorPierre-Jean Texier <pjtexier@koncepto.io>
Fri, 1 May 2020 12:19:28 +0000 (14:19 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 3 May 2020 14:38:03 +0000 (15:38 +0100)
The version 7.70.0 of curl add experimental support for this
protocol.

So, add PACKAGECONFIG for mqtt.

See [1] for more informations.

[1] - https://github.com/curl/curl/blob/master/docs/MQTT.md

Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/curl/curl_7.70.0.bb

index d3d8d2cacae619215e1d9c0dbc8b2c9121b4217a..baf72f8e757951c2d8e6716500348a40ee089f32 100644 (file)
@@ -34,6 +34,7 @@ PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
 PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2"
 PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
 PACKAGECONFIG[mbedtls] = "--with-mbedtls=${STAGING_DIR_TARGET},--without-mbedtls,mbedtls"
+PACKAGECONFIG[mqtt] = "--enable-mqtt,--disable-mqtt,"
 PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
 PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
 PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"