]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3-tomli: upgrade 1.2.1 -> 1.2.2
authorTim Orling <ticotimo@gmail.com>
Mon, 25 Oct 2021 22:44:04 +0000 (22:44 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 27 Oct 2021 08:44:59 +0000 (09:44 +0100)
1.2.2

  * Fixed
    - Illegal characters in error messages were surrounded by two
      pairs of quotation marks
  * Improved
    - TOMLDecodeError.__module__ is now the public import path (tomli)
      instead of private import path (tomli._parser)
    - Eliminated an import cycle when typing.TYPE_CHECKING is True.
      This allows sphinx-autodoc-typehints to resolve type annotations.

Signed-off-by: Tim Orling <timothy.t.orling@intel.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3-tomli_1.2.2.bb [moved from meta/recipes-devtools/python/python3-tomli_1.2.1.bb with 86% similarity]

similarity index 86%
rename from meta/recipes-devtools/python/python3-tomli_1.2.1.bb
rename to meta/recipes-devtools/python/python3-tomli_1.2.2.bb
index f62690ff2de8c00a3dddc38c63ea87592e87d278..39030ed218d64f1908bea470e724d1b03856d93c 100644 (file)
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5"
 
 inherit pypi setuptools3
 
-SRC_URI[sha256sum] = "a5b75cb6f3968abb47af1b40c1819dc519ea82bcc065776a866e8d74c5ca9442"
+SRC_URI[sha256sum] = "c6ce0015eb38820eaf32b5db832dbc26deb3dd427bd5f6556cf0acac2c214fee"
 
 do_configure:prepend() {
 cat > ${S}/setup.py <<-EOF