]> code.ossystems Code Review - openembedded-core.git/commitdiff
debianutils: create package for run-parts
authorJoe Slater <jslater@windriver.com>
Wed, 2 Sep 2015 22:24:20 +0000 (15:24 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 2 Sep 2015 22:51:16 +0000 (23:51 +0100)
Also add an RDEPENDS to dpkg so it will still
pull in run-parts.

Signed-off-by: Joe Slater <jslater@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/debianutils/debianutils_4.5.1.bb

index 9e5dd702f8ad710d91f2d3a1bab9439b2a523ff8..6b665fb2c3f879632a7cfafffd4b29128f59ece3 100644 (file)
@@ -26,8 +26,17 @@ do_install_append() {
     fi
 }
 
+# Note that we package the update-alternatives name.
+#
+PACKAGES =+ "${PN}-run-parts"
+FILES_${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
+
+RDEPENDS_${PN} += "${PN}-run-parts"
+
+
 ALTERNATIVE_PRIORITY="100"
-ALTERNATIVE_${PN} = "add-shell installkernel remove-shell run-parts savelog tempfile which"
+ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which"
+ALTERNATIVE_${PN}-run-parts = "run-parts"
 
 ALTERNATIVE_LINK_NAME[add-shell]="${sbindir}/add-shell"
 ALTERNATIVE_LINK_NAME[installkernel]="${sbindir}/installkernel"