]> code.ossystems Code Review - openembedded-core.git/commitdiff
nfs-utils: don't try to unload nfsd module
authorAndreas Oberritter <obi@opendreambox.org>
Mon, 30 Apr 2012 19:58:00 +0000 (21:58 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 3 May 2012 14:15:25 +0000 (15:15 +0100)
* When nfsserver get's stopped, "modprobe -r nfsd" may
  hang indefinitely. As there's no need to unload the
  module, just remove the call to modprobe.

Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-connectivity/nfs-utils/nfs-utils/nfsserver
meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb

index 69c871855f14e3948cc6bc071cea844fdb4ca1aa..e460e26af0f965388af97cfa4326c05883450c3e 100644 (file)
@@ -105,14 +105,6 @@ stop_nfsd(){
        }
        then
                echo done
-               # This will remove, recursively, dependencies
-               echo -n 'removing nfsd kernel module: '
-               if modprobe -r nfsd
-               then
-                       echo done
-               else
-                       echo failed
-               fi
        else
                echo failed
        fi
index d047940fd625d7addef9ffcddb5133959d1d9eaf..eb18aaaa945ce7c9ad72fbf3253b6dd72e8617ca 100644 (file)
@@ -12,7 +12,7 @@ DEPENDS = "libcap libnfsidmap libevent util-linux tcp-wrappers"
 RDEPENDS_${PN} = "portmap"
 RRECOMMENDS_${PN} = "kernel-module-nfsd"
 
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.bz2 \
            file://nfs-utils-1.0.6-uclibc.patch \