]> code.ossystems Code Review - openembedded-core.git/commitdiff
dtc: add patch to remove -Os for PPC
authorSaul Wold <sgw@linux.intel.com>
Sun, 2 Jan 2011 09:22:42 +0000 (01:22 -0800)
committerSaul Wold <sgw@linux.intel.com>
Sun, 2 Jan 2011 09:25:41 +0000 (01:25 -0800)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-kernel/dtc/dtc/remove_space_opt.patch [new file with mode: 0644]
meta/recipes-kernel/dtc/dtc_git.bb
meta/recipes-kernel/dtc/dtc_git.inc

diff --git a/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch b/meta/recipes-kernel/dtc/dtc/remove_space_opt.patch
new file mode 100644 (file)
index 0000000..805bf58
--- /dev/null
@@ -0,0 +1,16 @@
+Remove the -Os flag
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -18,7 +18,7 @@ CONFIG_LOCALVERSION =
+ CPPFLAGS = -I libfdt
+ WARNINGS = -Werror -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
+       -Wstrict-prototypes -Wmissing-prototypes
+-CFLAGS = -g -Os -fPIC -Werror $(WARNINGS)
++CFLAGS = -g -fPIC -Werror $(WARNINGS)
+ BISON = bison
+ LEX = flex
index 21f71e6e6ad49ccaeb6311df8087a187d93e994f..1cca32cedb5d7a769db3e8952bd9f9d19eae20c1 100644 (file)
@@ -4,3 +4,4 @@ LICENSE="GPLv2|BSD"
 LIC_FILES_CHKSUM = "file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
                    file://libfdt/libfdt.h;beginline=3;endline=52;md5=fb360963151f8ec2d6c06b055bcbb68c"
 
+SRC_URI += " file://remove_space_opt.patch"
index 9bcd63684997ac5876d257e3ec9e1bead6d6a3b0..96542f999cceb4d8bc5d0bc4912b2699a41c345d 100644 (file)
@@ -1,5 +1,5 @@
 SRC_URI = "git://www.jdl.com/software/dtc.git;protocol=git"
 PV = "1.2.0+git${SRCPV}"
-PR = "r1"
+PR = "r2"
 
 S = "${WORKDIR}/git"