]> code.ossystems Code Review - openembedded-core.git/commitdiff
systemd-serialtty: allow empty package
authorChen Qi <Qi.Chen@windriver.com>
Tue, 26 Sep 2017 08:41:38 +0000 (16:41 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 26 Sep 2017 10:07:36 +0000 (11:07 +0100)
If SERIAL_CONSOLES is set to empty for some reason, we would have rootfs
failure like below.

  - nothing provides systemd-serialgetty needed by systemd-1:234-r0.core2_64

This is because systemd-serialgetty package is not generated when
SERIAL_CONSOLES is empty.

Set ALLOW_EMPTY to "1" for this recipe to allow for generation of empty
systemd-serialgetty package to avoid the above error.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/systemd/systemd-serialgetty.bb

index 74b598673045f5970f4870f8156697d0b99d6200..d9347163b557426db2107ab8fe57096e587fe209 100644 (file)
@@ -48,3 +48,5 @@ python () {
     if not bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
         raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
 }
+
+ALLOW_EMPTY_${PN} = "1"