]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add 'home' button to panel hacks
authorMatthew Allum <mallum@openedhand.com>
Fri, 30 Sep 2005 13:55:42 +0000 (13:55 +0000)
committerMatthew Allum <mallum@openedhand.com>
Fri, 30 Sep 2005 13:55:42 +0000 (13:55 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@84 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop [new file with mode: 0644]
openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home [new file with mode: 0755]
openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks_0.3-1.bb

diff --git a/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/home-panelapp.desktop
new file mode 100644 (file)
index 0000000..4e08dfd
--- /dev/null
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Home
+Comment=Home
+Exec=mb-applet-home
+Type=PanelApp
+Icon=xrandr.png
+Categories=Panel;Utility;MB
diff --git a/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home b/openembedded/packages/matchbox-panel-hacks/matchbox-panel-hacks-0.3-1/mb-applet-home
new file mode 100755 (executable)
index 0000000..74f422e
--- /dev/null
@@ -0,0 +1,2 @@
+#!/bin/sh
+mb-applet-launcher -na -l --title "Home" mbdesktop.png matchbox-remote -d
index e7c1b4e6481d6e5c57c97c60655cae47a95c02dd..804bcab5584c336517bab5f3601783922c4f76f4 100644 (file)
@@ -2,10 +2,12 @@ DESCRIPTION = "Simple dockapps created with monolaunch and shell script"
 DEPENDS = "matchbox xmodmap"
 SRC_URI = "file://xrandr-panelapp.sh \
           file://xrandr-panelapp.desktop \
+          file://mb-applet-home \
+          file://home-panelapp.desktop \
           file://xrandr.png"
 SECTION = "x11/wm"
 PRIORITY = "optional"
-PR = "r4"
+PR = "r5"
 LICENSE = "MIT"
 
 do_install() {
@@ -15,4 +17,7 @@ do_install() {
        install -m 0755 ${WORKDIR}/xrandr-panelapp.sh ${D}${bindir}/
        install -m 0644 ${WORKDIR}/xrandr-panelapp.desktop ${D}${datadir}/applications/
        install -m 0644 ${WORKDIR}/xrandr.png ${D}${datadir}/pixmaps/
+       install -m 0755 ${WORKDIR}/mb-applet-home ${D}${bindir}/
+       install -m 0644 ${WORKDIR}/home-panelapp.desktop ${D}${datadir}/applications/
+
 }