]> code.ossystems Code Review - openembedded-core.git/commitdiff
build-appliance-image: Fix incorrect PATH
authorJuro Bystricky <juro.bystricky@intel.com>
Fri, 28 Oct 2016 22:14:56 +0000 (15:14 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 16 Nov 2016 10:33:32 +0000 (10:33 +0000)
When modifying the PATH variable in .bashrc, double quote characters
were used, resulting in expanding the variable $PATH with the value of
PATH of the system building the Build Appliance.

The original intent was to enter an un-expanded (literal) $PATH.
In order to that, one must use single quotes instead of double quotes.

[YOCTO#10434] [YOCTO#10504]

(From OE-Core rev: 6238faf901956e2a350315a66ca1ce557deaa513)

Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-core/images/build-appliance-image_15.0.0.bb

index e6ed0f482878e859275cb3c09a0b8c5196cbc4d6..633925ed6bb0e0e84dadfa005036bb76b25df70f 100644 (file)
@@ -63,7 +63,7 @@ fakeroot do_populate_poky_src () {
        # Also save (for reference only) the actual SRCREV used to create this image
        echo "export BA_SRCREV=${SRCREV}" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
        echo "" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
-       echo "export PATH=$PATH:/sbin" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
+       echo 'export PATH=$PATH:/sbin' >> ${IMAGE_ROOTFS}/home/builder/.bashrc
        echo "" >> ${IMAGE_ROOTFS}/home/builder/.bashrc
 
        echo "# If working behind a proxy and using the provided oe-git-proxy script" >> ${IMAGE_ROOTFS}/home/builder/.bashrc