]> code.ossystems Code Review - openembedded-core.git/commitdiff
pulseaudio: remove spurious cd in do_compile_prepend
authorRoss Burton <ross.burton@intel.com>
Thu, 11 Apr 2013 11:14:43 +0000 (12:14 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 11 Apr 2013 11:20:23 +0000 (12:20 +0100)
This prepend was cding to ${S}, which then breaks base_do_compile as it assumes
it's in ${B}.  The cd is pointless as all of the operations use absolute paths,
so remove it.

The result of this was that base_do_compile was failing to find the makefiles,
so the compilation happened in do_install.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-multimedia/pulseaudio/pulseaudio_3.0.bb

index 71c3c05640e672df288e95b95937347a22df2372..3621452d4cd619a71ad5755b4263eec1e68cb89a 100644 (file)
@@ -13,7 +13,6 @@ SRC_URI[md5sum] = "47fd7eca8479c757822bee68a1feef25"
 SRC_URI[sha256sum] = "c90bfda29605942d08e3e218ef10e3c660506a06651a616bfbb6a6df8392836d"
 
 do_compile_prepend() {
-    cd ${S}
     mkdir -p ${S}/libltdl
     cp ${STAGING_LIBDIR}/libltdl* ${S}/libltdl
 }