]> code.ossystems Code Review - openembedded-core.git/commitdiff
gmp: also generate the libgmpcxx library & package it properly
authorNitin A Kamble <nitin.a.kamble@intel.com>
Tue, 29 Nov 2011 19:30:38 +0000 (11:30 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 1 Dec 2011 20:38:41 +0000 (20:38 +0000)
configure runs few checks to make sure c++ compiler and runtime are working
as expected with the --enable-cxx=detect option. And it enables building
of libgmpxx library.

Same as earlier the libgmp.so.10.x file is packaged in the libgmp10 package,
and a new package named libgmpxx4 is added for libgmpxx.so.4.x file.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/gmp/gmp.inc
meta/recipes-support/gmp/gmp_5.0.2.bb

index 66349e6e2183c60fdbc3d8de6cf4fbae97106185..5ba118dabba731a74b44991bffab0cdc7efb5d9e 100644 (file)
@@ -14,3 +14,8 @@ ARM_INSTRUCTION_SET = "arm"
 acpaths = ""
 
 BBCLASSEXTEND = "native nativesdk"
+
+EXTRA_OECONF += " --enable-cxx=detect"
+
+PACKAGES =+ "libgmpxx"
+FILES_libgmpxx = "${libdir}/libgmpxx${SOLIBS}"
index 16bdcbc2b71cfe39aa8a65e19eb583af202dd494..873fc3ea0ee47d4bac5b2e86228f5e8cbd64e943 100644 (file)
@@ -2,7 +2,7 @@ require gmp.inc
 LICENSE="LGPLv3&GPLv3"
 LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
                    file://version.c;endline=18;md5=d8c56b52b9092346b9f93b4da65ef790"
-PR = "r1"
+PR = "r2"
 
 SRC_URI_append += "file://sh4-asmfix.patch \
                    file://use-includedir.patch "