]> code.ossystems Code Review - openembedded-core.git/commitdiff
pango: make x11 support conditional on DISTRO_FEATURES
authorPhil Blundell <philb@gnu.org>
Fri, 26 Aug 2011 14:23:02 +0000 (15:23 +0100)
committerSaul Wold <sgw@linux.intel.com>
Fri, 26 Aug 2011 19:34:03 +0000 (12:34 -0700)
This allows pango to build on DISTROs which don't enable x11.
Also adjust the SECTION since pango isn't really an X library.

Signed-off-by: Phil Blundell <philb@gnu.org>
meta/recipes-graphics/pango/pango.inc
meta/recipes-graphics/pango/pango_1.28.4.bb

index 5a8a5aef751fdcaa4e2a913a444e22a04711b36a..a8e99e2f6dd21e851e49edd8cca8b7f832ed5570 100644 (file)
@@ -6,14 +6,15 @@ been done in the context of the GTK+ widget toolkit. Pango forms the \
 core of text and font handling for GTK+-2.x."
 HOMEPAGE = "http://www.pango.org/"
 BUGTRACKER = "http://bugzilla.gnome.org"
-SECTION = "x11/libs"
+SECTION = "libs"
 LICENSE = "LGPL"
 
-DEPENDS = "glib-2.0 fontconfig freetype zlib virtual/libiconv virtual/libx11 libxft gtk-doc-native cairo"
+X11DEPENDS = "virtual/libx11 libxft"
+DEPENDS = "glib-2.0 fontconfig freetype zlib virtual/libiconv gtk-doc-native cairo ${@base_contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)}"
 
 PACKAGES_DYNAMIC = "pango-module-*"
 
-RRECOMMENDS_${PN} = "pango-module-basic-x pango-module-basic-fc" 
+RRECOMMENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'x11', 'pango-module-basic-x', '', d)} pango-module-basic-fc" 
 
 inherit gnome
 
@@ -24,7 +25,8 @@ FULL_OPTIMIZATION_arm = "-O2"
 
 EXTRA_OECONF = "--disable-glibtest \
                --enable-explicit-deps=no \
-               --disable-debug"
+               --disable-debug \
+               ${@base_contains('DISTRO_FEATURES', 'x11', '--with-x', '--without-x', d)}"
 
 LEAD_SONAME = "libpango-1.0*"
 LIBV = "1.6.0"
index 600f00b7400bdfe7c14fb83a7b0677168dda9429..68ab700c8c4d72bbf426cda9ff2c218300d7bc40 100644 (file)
@@ -2,7 +2,7 @@ require pango.inc
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
 
-PR = "r0"
+PR = "r1"
 
 SRC_URI += "file://no-tests.patch"