]> code.ossystems Code Review - openembedded-core.git/commitdiff
lzo: Upgrade to 2.09 and add ptest
authorSaul Wold <sgw@linux.intel.com>
Tue, 17 Feb 2015 23:00:12 +0000 (15:00 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 19 Feb 2015 07:50:44 +0000 (07:50 +0000)
lzo_init checksum changed due to date change, not license change

Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/lzo/lzo/run-ptest [new file with mode: 0644]
meta/recipes-support/lzo/lzo_2.09.bb [moved from meta/recipes-support/lzo/lzo_2.08.bb with 56% similarity]

diff --git a/meta/recipes-support/lzo/lzo/run-ptest b/meta/recipes-support/lzo/lzo/run-ptest
new file mode 100644 (file)
index 0000000..2ea7745
--- /dev/null
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+./lzotest -mavail -n10 -q /etc/services
+LZOTEST=./lzotest /bin/sh -e "./check.sh" "/etc"
+./align
+./chksum
+./simple
+./testmini
similarity index 56%
rename from meta/recipes-support/lzo/lzo_2.08.bb
rename to meta/recipes-support/lzo/lzo_2.09.bb
index af06e29a6f4549839d3ae816f5efa5831020d7b2..2978617bbd3536e9538c9815039a47fd593b3ca9 100644 (file)
@@ -3,17 +3,18 @@ HOMEPAGE = "http://www.oberhumer.com/opensource/lzo/"
 SECTION = "libs"
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
-                    file://src/lzo_init.c;beginline=5;endline=25;md5=a6e25df9a83b24629e847846ccdd8054"
+                    file://src/lzo_init.c;beginline=5;endline=25;md5=355023835a9b9eeb70ab895395e951ff"
 
 SRC_URI = "http://www.oberhumer.com/opensource/lzo/download/lzo-${PV}.tar.gz \
            file://0001-Use-memcpy-instead-of-reinventing-it.patch \
            file://acinclude.m4 \
+           file://run-ptest \
            "
 
-SRC_URI[md5sum] = "fcec64c26a0f4f4901468f360029678f"
-SRC_URI[sha256sum] = "ac1b3e4dee46febe9fd28737eb7f5692d3232ef1a01da10444394c3d47536614"
+SRC_URI[md5sum] = "c7ffc9a103afe2d1bba0b015e7aa887f"
+SRC_URI[sha256sum] = "f294a7ced313063c057c504257f437c8335c41bfeed23531ee4e6a2b87bcb34c"
 
-inherit autotools
+inherit autotools ptest
 
 EXTRA_OECONF = "--enable-shared"
 
@@ -21,4 +22,14 @@ do_configure_prepend () {
        cp ${WORKDIR}/acinclude.m4 ${S}/
 }
 
+do_install_ptest() {
+       t=${D}${PTEST_PATH}
+       cp ${S}/util/check.sh $t
+       cp ${B}/minilzo/testmini $t
+       for i in tests/align tests/chksum lzotest/lzotest examples/simple
+               do cp ${B}/`dirname $i`/.libs/`basename $i` $t; \
+       done
+}
+
+
 BBCLASSEXTEND = "native nativesdk"