]> code.ossystems Code Review - openembedded-core.git/commitdiff
linuxdoc-tools: use snapshot.debian.org for SRC_URI
authorMaxin B. John <maxin.john@intel.com>
Thu, 28 Jul 2016 12:46:51 +0000 (15:46 +0300)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 1 Aug 2016 11:14:19 +0000 (12:14 +0100)
Using ${DEBIAN_MIRROR} for SRC_URI doesn't work very well as that will
only contain releases that are currently in Debian. So, move all of SRC_URI
to the .bb so it can use snapshot.debian.org instead, and set
UPSTREAM_CHECK_URI to ${DEBIAN_MIRROR} so upstream release checking continues
to work.

[YOCTO #10040]

Signed-off-by: Maxin B. John <maxin.john@intel.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.69.bb

index a8a90fc82e6bb966af5e04a2d4577834b12cc10d..a5deb2e2d58d4df7fc0f6633364bd74835411c6c 100644 (file)
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=077ef64ec3ac257fb0d786531cf26931"
 
 DEPENDS = "groff-native openjade-native"
 
-SRC_URI = "${DEBIAN_MIRROR}/main/l/linuxdoc-tools/linuxdoc-tools_${PV}.orig.tar.gz \
+SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/l/${BPN}/${BPN}_${PV}.orig.tar.gz \
            file://disable_sgml2rtf.patch \
            file://disable_txt_doc.patch \
            file://disable_tex_doc.patch \
@@ -14,6 +14,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/l/linuxdoc-tools/linuxdoc-tools_${PV}.orig.tar.
 SRC_URI[md5sum] = "1d13d500918a7a145b0edc2f16f61dd1"
 SRC_URI[sha256sum] = "7103facee18a2ea97186ca459d743d22f7f89ad4b5cd1dfd1c34f83d6bfd4101"
 
+UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/l/linuxdoc-tools/"
 inherit autotools-brokensep native
 
 do_configure () {