]> code.ossystems Code Review - openembedded-core.git/commitdiff
meta-toolchain: Fix libGL.so not found issues
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 8 Oct 2010 14:20:42 +0000 (15:20 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 8 Oct 2010 14:20:42 +0000 (15:20 +0100)
Fix libGL.so not found issues by making sure ld.so.cache from the host system
is used to locate libraries.

Also, fix a /usr/ reference that should be /var to keep the installation
tarball clean.

[BUGID #228]

Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/recipes-tbd/meta/meta-toolchain.bb

index 8054b5f7b83acc0c67e5331a1bbc5830e46996e3..f976457bc568339d8b0cbf6eb2d4f9caf094d48c 100644 (file)
@@ -47,7 +47,7 @@ do_populate_sdk() {
 
        install -d ${SDK_OUTPUT}/${SDKPATHNATIVE}${localstatedir_nativesdk}/lib/opkg
        mv ${SDK_OUTPUT}/var/lib/opkg/* ${SDK_OUTPUT}/${SDKPATHNATIVE}${localstatedir_nativesdk}/lib/opkg/
-       rm -Rf ${SDK_OUTPUT}/usr
+       rm -Rf ${SDK_OUTPUT}/var
 
        # Don't ship any libGL in the SDK
        rm -rf ${SDK_OUTPUT}/${SDKPATHNATIVE}${libdir_nativesdk}/libGL*
@@ -72,6 +72,9 @@ do_populate_sdk() {
        #rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}/lib/*.la
        rm -f ${SDK_OUTPUT}/${SDKPATHNATIVE}${libdir_nativesdk}/*.la
 
+       # Link the ld.so.cache file into the hosts filesystem
+       ln -s /etc/ld.so.cache ${SDKPATHNATIVE}/etc/ld.so.cache
+
        # Setup site file for external use
        siteconfig=${SDK_OUTPUT}/${SDKPATH}/site-config-${MULTIMACH_TARGET_SYS}
        touch $siteconfig