]> code.ossystems Code Review - openembedded-core.git/commitdiff
handbook: Various minor fixes
authorRichard Purdie <rpurdie@linux.intel.com>
Fri, 10 Sep 2010 11:32:48 +0000 (12:32 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Fri, 10 Sep 2010 11:32:48 +0000 (12:32 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
handbook/extendpoky.xml
handbook/ref-classes.xml
handbook/ref-structure.xml
handbook/ref-variables.xml

index 61620053a6cabeff38168bb07227ea5e92412ad9..662096844d090033e127e89318c3f03cfc6dda50 100644 (file)
@@ -74,8 +74,8 @@ do_install() {
 
             <para>
                 As a result of the build process "helloworld", "helloworld-dbg" and "hellworld-dev"
-                packages will be built by default. You can <link linkend='usingpoky-extend-addpkg-files'>
-                    control package process</link> yourself.
+                packages will be built by default. It is possible to<link linkend='usingpoky-extend-addpkg-files'>
+                customise the packaging process</link>.
             </para>
         </section>
 
@@ -243,8 +243,8 @@ FILES_sxpm = "${bindir}/sxpm"
             </para>
             <programlisting>
 pkg_postinst_PACKAGENAME () {
-       #!/bin/sh -e
-       # Commands to carry out
+#!/bin/sh -e
+# Commands to carry out
 }
             </programlisting>
             <para>
@@ -265,12 +265,12 @@ pkg_postinst_PACKAGENAME () {
             
             <programlisting>
 pkg_postinst_PACKAGENAME () {
-       #!/bin/sh -e
-       if [ x"$D" = "x" ]; then
-               # Actions to carry out on the device go here
-       else
-               exit 1
-       fi
+#!/bin/sh -e
+if [ x"$D" = "x" ]; then
+       # Actions to carry out on the device go here
+else
+       exit 1
+fi
 }
             </programlisting>
             
@@ -398,7 +398,7 @@ RRECOMMENDS_task-custom-tools = "\
                 variable. To create these, the best reference is <filename>meta/classes/poky-image.bbclass</filename>
                 which illustrates how poky achieves this. In summary, the file looks at the contents of the 
                 <glossterm><link linkend='var-IMAGE_FEATURES'>IMAGE_FEATURES</link></glossterm>
-                variable and then map into a set of tasks or packages. Based on this then the 
+                variable and then maps this into a set of tasks or packages. Based on this then the 
                 <glossterm><link linkend='var-IMAGE_INSTALL'> IMAGE_INSTALL</link></glossterm> 
                 variable is generated automatically. Extra features can be added by 
                 extending the class or creating a custom class for use with specialised image .bb files.
@@ -586,12 +586,11 @@ DISPLAY_SUBPIXEL_ORDER=vrgb
 
            <para>
                The Poky tree includes several additional layers which demonstrate
-               this functionality, such as meta-moblin, meta-emenlow, meta-extras.
-               Default layers enabled are meta-moblin and meta-emenlow, which may
-               suffer from future changes. The meta-extras repostory is not enabled 
-               by default but enabling any layer is as easy as adding the layers path 
-               to the BBLAYERS variable in your bblayers.conf. this is how meta-extras
-               are enabled in Poky builds:
+               this functionality, such as meta-emenlow and meta-extras.
+               The meta-emenlow layer is an example layer enabled by default. The meta-extras 
+               repostory is not enabled by default but enabling any layer is as easy as adding
+               the layers path to the BBLAYERS variable in your bblayers.conf. this is how 
+               meta-extras are enabled in Poky builds:
           </para>
           <para>
                <literallayout class='monospaced'>LCONF_VERSION = "1"
@@ -650,7 +649,8 @@ BBFILE_PRIORITY_emenlow = "6"
             </para>
 
             <para>
-                Emenlow bbclasses and configuration are added to the BBPATH
+                Additional bbclass and configuration files can be locationed by 
+                bitbake through the addition to the BBPATH
                 environment variable. In this case, the first file with the
                 matching name found in BBPATH is the one that is used, just
                 like the PATH variable for binaries. It is therefore recommended
@@ -773,7 +773,7 @@ BBFILE_PRIORITY_emenlow = "6"
                 They usually happen at preset times such as at night when the machine 
                 load isn't high from the incremental builds.
                 <ulink url='http://autobuilder.pokylinux.org:8010'>poky autobuilder</ulink>
-                is an example implementation with buildrot.
+                is an example implementation with buildbot.
             </para>
 
             <para>
@@ -856,7 +856,7 @@ bitbake -c compile -f NAME_OF_PACKAGE
             "-f" or "--force" is used to force re-execution of the specified task.
             Other tasks may also be called this way. But note that all the modifications
             in <glossterm><link linkend='var-WORKDIR'>WORKDIR</link></glossterm>
-            are gone once you executes "-c clean" for a pacakge.
+            are gone once you executes "-c clean" for a package.
         </para>
 
         <section id='usingpoky-modifying-packages-quilt'>
index 770c062e712d6169aa2b76320666d2c5128251f0..036044dd28ea50df5203c63241ad5328cffde327 100644 (file)
@@ -60,7 +60,7 @@
     <itemizedlist>
       <listitem>
         <para>
-            'do_configure' regenearates the configure script and (using autoreconf)
+            'do_configure' regenearates the configure script (using autoreconf) and
             then launches it with a standard set of arguments used during
             cross-compilation. Additional parameters can be passed to 
             <command>configure</command> through the <glossterm><link 
index 3d7c3c9db7a91eb5ba82b9a4270860b908833c63..ca589de428b2c4c6d9065a35d9a4953d572aa6ac 100644 (file)
 
         <para>
             This directory contains user configuration files and the output 
-            from Poky. It's now deprecated to be a sub-directory in Poky source tree,
-            though it's still supported. The desired way is to use <link 
-            linkend='structure-core-script'>seperate output directory</link> for build
-            outside of Poky source tree.
+            generated by Poky in its standard configuration where the source tree is 
+            combined with the output. It is also possible to place output and configuration 
+            files in a directory separate from the Poky source, see the section <link 
+            linkend='structure-core-script'>seperate output directory</link>.
         </para>
     </section>
 
             a shell makes changes to PATH and sets other core BitBake variables based on the
             current working directory. You need to use this before running Poky commands.
             Internally it uses scripts within the <filename class="directory">scripts/ 
-            </filename> directory to do the bulk of the work. Now this script supports
+            </filename> directory to do the bulk of the work. This script supports
             specifying any directory as the build output:
         </para>
 
@@ -145,9 +145,9 @@ source POKY_SRC/poky-init-build-env [BUILDDIR]
         </programlisting>
 
         <para>
-            Above command can be typed from any directory, as long as POKY_SRC points to
+            The above command can be typed from any directory, as long as POKY_SRC points to
             the desired Poky source tree. The optional BUILDDIR could be any directory you'd
-            like to contain output contents.
+            like Poky to generate the build output into.
         </para>
     </section>
 </section>
@@ -182,7 +182,7 @@ source POKY_SRC/poky-init-build-env [BUILDDIR]
         <para>
             This file defines layers walked by bitbake. If there's no <filename>
             bblayers.conf</filename> present, it is created from <filename>bblayers.conf.sample
-            </filename>.
+            </filename> when the environment setup script is sourced.
         </para>
     </section>
 
index de51dff1aad9ad79b1896e46c074489c657bce44..ef1e85cfbaafe569995abbe5f3babab41c1e4489 100644 (file)
                 <para>A regular expression which evalutates to match the machines the recipe 
                 works with. It stops recipes being run on machines they're incompatible with, 
                 which is partciuarly useful with kernels. It also helps to increase parsing 
-                speed that, further parsing of the recipe is skipped as if it found the current
+                speed as further parsing of the recipe is skipped as if it found the current
                 machine is not compatible.</para>
             </glossdef>
         </glossentry>