]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl-native: unset configure symbol i_xlocale
authorKai Kang <kai.kang@windriver.com>
Mon, 21 Jan 2019 14:48:24 +0000 (09:48 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 21 Jan 2019 23:46:46 +0000 (23:46 +0000)
perl-native checks xlocale.h on build machine. But xlocale.h has been
removed by glibc already. When use share state caches between machines
that one has xlocale.h but the other one doesn't, it causes packages
which depend on perl-native such as libdbi-perl-native fails to compile:

| In file included from DBIXS.h:23,
|                  from Perl.xs:7:
| .../tmp-glibc/work/x86_64-linux/libdbi-perl-native/1.642-r0/recipe-sysroot-native/usr/lib/perl5/5.28.1/x86_64-linux/CORE/perl.h:723:13:
| fatal error: xlocale.h: No such file or directory
|  #   include <xlocale.h>
|        ^~~~~~~~~~~
| compilation terminated.

Unset configure symbol i_xlocale for perl-native to fix the issue.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl-sanity/perl_5.28.1.bb

index 949758c4d493dd2941feec55c9e6b0876cd286f1..176980e1b2abbee8e9a8e3aa9a87ac2b6e261660 100644 (file)
@@ -82,7 +82,8 @@ do_configure_class-native() {
     -Dbin=${bindir}/perl-native \
     -Duseshrplib \
     -Dsoname=libperl.so.5 \
-    -Dvendorprefix=${prefix}
+    -Dvendorprefix=${prefix} \
+    -Ui_xlocale
 }
 
 do_compile() {