]> code.ossystems Code Review - openembedded-core.git/commitdiff
wayland: Add target sysroot scanner m4 macro
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 7 Mar 2014 10:49:59 +0000 (10:49 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 7 Mar 2014 14:44:25 +0000 (14:44 +0000)
With the new aclocals process, accesses to the macros is a lot stricter and
the native macros are not used. We need to ensure the modified macros are used
in target builds to get the correct scanner functionality. Inserting the
native macro into the target is the correct thing to do in this case.

This resolves build failures in libva.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/wayland/wayland_1.4.0.bb

index 0f08cacfeab55ec4b499921f68d9cec8c2b25240..604b7f4c543990358bfd8a7252f1bbf43fbadf3d 100644 (file)
@@ -34,3 +34,7 @@ do_install_append_class-native() {
       -e 's,$PKG_CONFIG,pkg-config-native,g' \
       -i ${D}/${datadir}/aclocal/wayland-scanner.m4
 }
+
+sysroot_stage_all_append_class-target () {
+       cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
+}