]> code.ossystems Code Review - openembedded-core.git/commitdiff
iproute2: update to 3.0.0 to fix build with updated iptables
authorKoen Kooi <koen@dominion.thruhere.net>
Thu, 3 Nov 2011 09:52:50 +0000 (10:52 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 7 Nov 2011 14:03:37 +0000 (14:03 +0000)
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
meta/recipes-connectivity/iproute2/iproute2-3.0.0/configure-cross.patch [moved from meta/recipes-connectivity/iproute2/iproute2-2.6.38/configure-cross.patch with 50% similarity]
meta/recipes-connectivity/iproute2/iproute2.inc
meta/recipes-connectivity/iproute2/iproute2_2.6.38.bb [deleted file]
meta/recipes-connectivity/iproute2/iproute2_3.0.0.bb [new file with mode: 0644]

similarity index 50%
rename from meta/recipes-connectivity/iproute2/iproute2-2.6.38/configure-cross.patch
rename to meta/recipes-connectivity/iproute2/iproute2-3.0.0/configure-cross.patch
index e26e8effd64b3e6b57706201b71e0789d12acca7..92c12be83e9009ccd7ddf9e4bd9585ebeeaca259 100644 (file)
@@ -1,31 +1,38 @@
+From 85b0589b4843c03e8e6fd9416d71ea449a73c5c0 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Thu, 3 Nov 2011 10:46:16 +0100
+Subject: [PATCH] make configure cross compile safe
+
+According to Kevin Tian:
 Upstream-Status: Pending
 
-# borrow from OE, to handle cross compile mess
-#
-# ktian1, 06/28/2010 
-Index: iproute2-2.6.34/configure
-===================================================================
---- iproute2-2.6.34.orig/configure
-+++ iproute2-2.6.34/configure
-@@ -4,7 +4,7 @@
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ configure |   13 +++++++------
+ 1 files changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/configure b/configure
+index f5c3d40..bcc1948 100755
+--- a/configure
++++ b/configure
+@@ -2,6 +2,7 @@
+ # This is not an autconf generated configure
+ #
  INCLUDE=${1:-"$PWD/include"}
- TABLES=
--
 +SYSROOT=$1
  check_atm()
  {
- cat >/tmp/atmtest.c <<EOF
-@@ -15,7 +15,7 @@ int main(int argc, char **argv) {
+@@ -13,7 +14,7 @@ int main(int argc, char **argv) {
        return 0;
  }
  EOF
 -gcc -I$INCLUDE -o /tmp/atmtest /tmp/atmtest.c -latm >/dev/null 2>&1 
-+$CC -I$INCLUDE -o /tmp/atmtest /tmp/atmtest.c -latm >/dev/null 2>&1
++$CC -I$INCLUDE -o /tmp/atmtest /tmp/atmtest.c -latm >/dev/null 2>&1 
  if [ $? -eq 0 ]
  then
      echo "TC_CONFIG_ATM:=y" >>Config
-@@ -49,7 +49,7 @@ int main(int argc, char **argv)
+@@ -47,7 +48,7 @@ int main(int argc, char **argv)
  
  EOF
  
@@ -34,7 +41,7 @@ Index: iproute2-2.6.34/configure
  then
        echo "TC_CONFIG_XT:=y" >>Config
        echo "using xtables"
-@@ -86,7 +86,7 @@ int main(int argc, char **argv) {
+@@ -84,7 +85,7 @@ int main(int argc, char **argv) {
  }
  
  EOF
@@ -43,7 +50,7 @@ Index: iproute2-2.6.34/configure
  
  if [ $? -eq 0 ]
  then
-@@ -126,7 +126,7 @@ int main(int argc, char **argv) {
+@@ -124,7 +125,7 @@ int main(int argc, char **argv) {
  }
  
  EOF
@@ -52,12 +59,24 @@ Index: iproute2-2.6.34/configure
  
  if [ $? -eq 0 ]
  then
-@@ -150,7 +150,7 @@ check_ipt()
+@@ -145,7 +146,7 @@ check_ipt()
  check_ipt_lib_dir()
  {
        IPT_LIB_DIR=""
 -      for dir in /lib /usr/lib /usr/local/lib
 +      for dir in $SYSROOT/lib $SYSROOT/usr/lib $SYSROOT/usr/local/lib
        do
-               for file in $dir/$TABLES/lib*t_*so ; do
+               for file in $dir/{xtables,iptables}/lib*t_*so ; do
                        if [ -f $file ]; then
+@@ -168,7 +169,7 @@ int main(int argc, char **argv)
+       return 0;
+ }
+ EOF
+-gcc -I$INCLUDE -o /tmp/setnstest /tmp/setnstest.c >/dev/null 2>&1
++$CC -I$INCLUDE -o /tmp/setnstest /tmp/setnstest.c >/dev/null 2>&1
+ if [ $? -eq 0 ]
+ then
+       echo "IP_CONFIG_SETNS:=y" >>Config
+-- 
+1.7.2.5
+
index 0f27a01465fde01b08aea7bdd00b3212d551d8e3..6fc30a05e1894f351017350a2f0db8d94cae71da 100644 (file)
@@ -23,8 +23,11 @@ do_install () {
     rm ${D}/share -rf || true
 }
 
-FILES_${PN} += "/usr/lib/tc/*"
-FILES_${PN}-dbg += "/usr/lib/tc/.debug"
+# There are only .so files in iproute2
+INSANE_SKIP_${PN} = "dev-so"
+
+FILES_${PN} += "${base_libdir}/tc/*"
+FILES_${PN}-dbg += "${base_libdir}/tc/.debug"
 
 ALTERNATIVE_NAME = "ip"
 ALTERNATIVE_PATH = "${base_sbindir}/ip.iproute2"
diff --git a/meta/recipes-connectivity/iproute2/iproute2_2.6.38.bb b/meta/recipes-connectivity/iproute2/iproute2_2.6.38.bb
deleted file mode 100644 (file)
index 7abc41f..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-require iproute2.inc
-
-PR = "r0"
-
-SRC_URI = "http://developer.osdl.org/dev/iproute2/download/${BPN}-${PV}.tar.bz2 \
-          file://configure-cross.patch"
-
-SRC_URI[md5sum] = "a243bfea837e71824b7ca26c3bb45fa8"
-SRC_URI[sha256sum] = "47629a4f547f21d94d8e823a87dd8e13042cadecefea2e2dc433e4134fa9aec4"
diff --git a/meta/recipes-connectivity/iproute2/iproute2_3.0.0.bb b/meta/recipes-connectivity/iproute2/iproute2_3.0.0.bb
new file mode 100644 (file)
index 0000000..8d1db85
--- /dev/null
@@ -0,0 +1,8 @@
+require iproute2.inc
+
+#v3.0.0 tag
+SRCREV = "ce691fb5ce78b2c75243c60a757a3990ae09681c"
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git \
+           file://configure-cross.patch"
+S = "${WORKDIR}/git"
+