]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add pax-utils for insane.bbclass
authorRoss Burton <ross@openedhand.com>
Mon, 22 Jan 2007 17:02:26 +0000 (17:02 +0000)
committerRoss Burton <ross@openedhand.com>
Mon, 22 Jan 2007 17:02:26 +0000 (17:02 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1194 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/pax-utils/pax-utils-native_0.1.13.bb [new file with mode: 0644]
meta/packages/pax-utils/pax-utils_0.1.13.bb [new file with mode: 0644]

diff --git a/meta/packages/pax-utils/pax-utils-native_0.1.13.bb b/meta/packages/pax-utils/pax-utils-native_0.1.13.bb
new file mode 100644 (file)
index 0000000..d586dcb
--- /dev/null
@@ -0,0 +1,7 @@
+inherit native
+
+require pax-utils_${PV}.bb
+
+do_stage() {
+    oe_runmake PREFIX=${STAGING_DIR}/${HOST_SYS} install
+}
diff --git a/meta/packages/pax-utils/pax-utils_0.1.13.bb b/meta/packages/pax-utils/pax-utils_0.1.13.bb
new file mode 100644 (file)
index 0000000..6fc6850
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "Various ELF utilities"
+HOMEPAGE    = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
+LICENSE     = "GPLv2"
+
+SRC_URI     = "${GENTOO_MIRROR}/pax-utils-${PV}.tar.bz2;md5sum=5f09df47a16e83462384b44b75310539"
+S           = "${WORKDIR}/pax-utils-${PV}"
+
+CPPFLAGS   += "-D_GNU_SOURCE "
+
+do_compile() {
+    oe_runmake
+}
+
+do_install() {
+    oe_runmake DESTDIR=${D} install
+}
+