]> code.ossystems Code Review - openembedded-core.git/commitdiff
libsdl 1.2.14: fix packaging
authorKoen Kooi <koen@dominion.thruhere.net>
Sun, 18 Dec 2011 10:09:27 +0000 (11:09 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 19 Dec 2011 12:17:36 +0000 (12:17 +0000)
For some reason the -config script was shipped in ${PN} leading to shlibs renaming issues:

What we want, and how meta-oe used to do it:
libsdl-1.2-0_1.2.14-r0.0_armv7a.ipk

Current OE-core status:
libsdl_1.2.14-r2_armv7a.ipk

With this commit we get both proper shlib renaming and the -dev package now has all the dev files

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/libsdl/libsdl_1.2.14.bb

index a28a88a9ee4118422a0c3d74f0be258875c6fa5f..f587291b526e7d5870225adddf90645622fb4c91 100644 (file)
@@ -15,7 +15,7 @@ PROVIDES = "virtual/libsdl"
 DEPENDS = "${@base_contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl', '', d)} virtual/libx11 libxext libxrandr libxrender tslib"
 DEPENDS_virtclass-nativesdk = "libx11-nativesdk libxrandr-nativesdk libxrender-nativesdk libxext-nativesdk"
 
-PR = "r2"
+PR = "r4"
 
 SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
            file://configure_tweak.patch \
@@ -26,7 +26,7 @@ S = "${WORKDIR}/SDL-${PV}"
 SRC_URI[md5sum] = "e52086d1b508fa0b76c52ee30b55bec4"
 SRC_URI[sha256sum] = "5d927e287034cb6bb0ebccfa382cb1d185cb113c8ab5115a0759798642eed9b6"
 
-inherit autotools binconfig pkgconfig
+inherit autotools lib_package binconfig pkgconfig
 
 EXTRA_OECONF = "--disable-static --disable-debug --enable-cdrom --enable-threads --enable-timers --enable-endian \
                 --enable-file --disable-oss --disable-esd --disable-arts \