]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto: safely process unbranched repositories
authorBruce Ashfield <bruce.ashfield@windriver.com>
Fri, 8 Apr 2011 04:01:35 +0000 (00:01 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 5 May 2011 10:54:47 +0000 (11:54 +0100)
The BSP bootstrap and -dev use cases can be applied against
unbranched or repos without meta data. To allow the proper
and safe processing of those repositories, slight modifications
to the tools are required to pass the branch on the command
line (rather than detecting it always) and to only checkout
branches that exist.

Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
meta/classes/kernel-yocto.bbclass
meta/recipes-kernel/kern-tools/kern-tools-native_git.bb

index 78a13099eef3af74f029454f9e31aea5e58b03a2..ffc0b4c6ee7e0ab297a813d68ee485f183b277d5 100644 (file)
@@ -25,7 +25,7 @@ do_patch() {
                        addon_features="$addon_features --feature $feat"
                done
        fi
-       updateme ${addon_features} ${ARCH} ${MACHINE} ${WORKDIR}
+       updateme --branch ${kbranch} ${addon_features} ${ARCH} ${MACHINE} ${WORKDIR}
        if [ $? -ne 0 ]; then
                echo "ERROR. Could not update ${kbranch}"
                exit 1
@@ -87,9 +87,12 @@ do_kernel_configme() {
        if [ -n "${YOCTO_KERNEL_EXTERNAL_BRANCH}" ]; then
            # switch from a generic to a specific branch
            kbranch=${YOCTO_KERNEL_EXTERNAL_BRANCH}
+           cd ${S}
+           git checkout ${kbranch}
+       else
+          cd ${S}
        fi
 
-       cd ${S}
        configme --reconfig --output ${B} ${kbranch} ${MACHINE}
        if [ $? -ne 0 ]; then
                echo "ERROR. Could not configure ${KMACHINE}-${LINUX_KERNEL_TYPE}"
index cc711790a151618bf4cb64fdf88084b05f137f3b..820765e8a2e4caa6a2a22e43f8cab3404b2ef0f9 100644 (file)
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=e2bf4415f3d8
 
 DEPENDS = "git-native guilt-native"
 
-SRCREV = "92b965b02e3ac32badde3ee71a1e7d3a85cedeb8"
+SRCREV = "c5896a60acc61f8966cfee3bb241ff564610cea4"
 PR = r10
 PV = "0.1+git${SRCPV}"